Archived

This topic is now archived and is closed to further replies.

zerkms

Utorrent does not always rename .!ut files, v3.4.2 build 38913

Recommended Posts

That is - sometimes it just leaves the file with .!ut extension even though the file is completely downloaded: it shows 100%, passes re-check and is literally a valid downloaded file.

Share this post


Link to post
Share on other sites

Same issue... only since last update to v3.4.2. I think it's mostly happening if I have uTorrent set to auto close or shutdown when down downloading. Haven't confirmed it yet but, a bit annoying. Easily fixed but annoying.

Share this post


Link to post
Share on other sites

Not for me... download finishes, delete the file from the list and .!ut still there.

 

Downloading a TV series right now, 12 files, half show 100% done but in the download folder all still show .!ut... and it's happening more frequently as well.

Share this post


Link to post
Share on other sites

That is - sometimes it just leaves the file with .!ut extension even though the file is completely downloaded: it shows 100%, passes re-check and is literally a valid downloaded file.

Same here, even when the entire torrent has finished downloading, it often times doesn't go back and rename the files to remove the !ut extension.

 

 

Same issue... only since last update to v3.4.2. I think it's mostly happening if I have uTorrent set to auto close or shutdown when down downloading. Haven't confirmed it yet but, a bit annoying. Easily fixed but annoying.

Nope, that's not it.  I don't have it set to do either of those things.  In fact, mine is set to just do nothing special.

 

 

I believe there is another issue at play here that is causing this issue.  When you go to recheck files, uT will allocate the !ut files even if the selected files are there (completed, correctly named, etc).  It's as if it doesn't "see" that the file is there and creates the !ut file to reserve the space for it.  What makes it worse is sometimes when you do a recheck in hopes of getting it to rename multiple files to remove the !ut extension, it creates the 'correct' file names (without the !ut on it) but those are bogus files.

 

One work around that sometimes works is to start the torrent again (if it's not stopped, then stop it and start it again).  After it starts and sees it's finished, it renames the files as it should.  But that is sometimes, not every time.

 

Maybe the other issue I mentioned isn't related but I have a feeling it is.  To put it into programming speak (sort of), it seems like it's skipping a step at times or a value isn't properly set (which if set properly would trigger the step that seems like is being skipped).  Like with the creation of the bogus files, it's like it's randomly not checking to see if files are already there and allocating the files (without the !ut extension) but once they're made, it forgets about them and uses the !ut files that were already there.  (I know they are bogus because when I compared them, the !ut files had the correct information and the non !ut files were useless.) From experience, such seeming randomness is often the result of a variable either not being set or it is being set but isn't being correctly referenced.

 

I'm curious as to if my hunch is right that either a value isn't being set or a typo was made.

Share this post


Link to post
Share on other sites

I do sometimes, don't other times... never checked which it happens on but will keep an eye open next time.

 

Though last night I grabbed a 12 file torrent, I downloaded everything, and the files that in uTorrent showed as 100% complete didn't change the file names until all files showed 100% complete, which it didn't do before. I could watch a file while the rest was downloading. Handy if downloading a season, because I can set priority higher on the first few episodes so they finish first and I can watch them while the rest download.

 

Makes sense though... if uTorrent is waiting for all files to finish before renaming, and not all files are selected, it never finishes.

 

In which case, I hope it gets changed back, else what's the point in being able to select/deselect files in multi-file torrents. :)

Share this post


Link to post
Share on other sites

How many of you are skipping files in multi-file torrents?

I've noticed that this is always the case for me. The .!ut does not get removed if and only if I skip files in multi-file torrents.

Share this post


Link to post
Share on other sites

Yes, it happens to me too on 3.4.3 build 39944 too. I don't remember having this issue a few builds earlier.

The only solution is to change the priority of the affected files to something else and then change them again. Now it removes the .!ut extension.

As others have mentioned, it seems to be happening when some files are skipped in the file list.

Windows 8.1 64-bit

P.S. This reply box is still as broken as it was months ago on IE11. I have to click that switch button on the top-left to be able to type properly.

Share this post


Link to post
Share on other sites

The same renaming issues is happening in v3.4.3 build 39944 (32-bit) on Win 8.1 64-bit.  I prefer using the .!UT option showing incomplete torrents and I can duplicate the problem consistently by selecting 1 of multiple files in a torrent for download only.  After it completes, I then select one of the other skipped files for download.  It renames the other previous file and removes the .dat file properly at that point.  The trick doesn’t always work though because uTorrent likes to download small files like txt file notes even if you’ve asked it to skip them.  Just thought I'd offer my 2 cents here since.  So much for squashing this bug in the next build.  I hope this gets corrected soon.

Share this post


Link to post
Share on other sites

Agree, the .!ut extension stays till the series is downloaded 100%. No files skipped. Workaround, unselect in the General options the "Append .!ut to incomplete files" and then select it again. It will append .!ut only to those files that are really incomplete. My version is 3.4.3 build 40760 on a 32 bit Windows 7 system.

Share this post


Link to post
Share on other sites

It is very difficult to recreate this, at least in latest build 40854. So let me suggest this:

 

Get this (legal and small) torrent , with many files, and try to show exact repro-steps to recreate:

http://bt.etree.org/details.php?id=580708

 

The "best" I could do was:

- sort by first piece

- skip all except the first 6

- download

- stop seeding

- delete *all* the files

- set to skip all but the 7th sond

- force recheck

- download again

 

At this point, I was able to see strange things, like - what seems to be:

- first+last pieces of the first 6  being downloaded (into partfile )

-  seeding color -> stays  the download color

- DL not stopping at more then 100%...

- 7th files stays as ~ut, until I stopped the torrent and restarted it...

 

But - These "steps" are not natural... plus no *permanent* ~uT leftovers... So, maybe one of you can do better...

 

PS: settings are per my sig file.

 

a4fea7427812718.jpg

 

 

6ba686427813495.jpg

Share this post


Link to post
Share on other sites

It is very difficult to recreate this, at least in latest build 40854. So let me suggest this:

Why are you using build 40854? Isn't the latest stable 40760?

 

Recreating this issue is quite simple.

 

1. Start a torrent download.

2. Select a few files and skip a few others.

3. Set the priority of one or two files to high, so that they download first and you can see the issue better.

4. Now observe that when those one or two files reach 100%, utorrent doesn't remove the .!ut extension, WHILE the torrent is still being downloaded.

5. The workaround is to stop the torrent, which in that case utorrent removes the extension.

 

Here is a video of the issue.

 

http://1drv.ms/1htbpFB

 

Onedrive cannot play it. Download and play it on your computer.

Share this post


Link to post
Share on other sites

Cannot play it in FF.

BTW, a more common use-case is - first load the torrent (stopped) select files, then start, or use the add-torrent dialog to pre-select.

And 40854 is the latest (beta).

Share this post


Link to post
Share on other sites