Jump to content

After Uninstalling McAfee, uTorrent no longer downloads


Recommended Posts

I have uTorrent set up on my laptop running through a VPN with a DNS Leak patch enabled; all tests show that I am fully anonymous and encrypted and this setup worked fine for a day or so.  But then I decided the nag popups to renew a McAfee subscription were too annoying to stand any further and removed it from my laptop using the removal tool McAfee provides on their website (foolish I know, but I was in a rush and irritated).  Ever since, uTorront has stopped downloading.  Torrents import fine, but then hang indefinitely, the progress bars of torrents with already downloaded data go from blue to maroon, others stay grey and just sit at 0%...

I get 'DHT waiting to log in' along the bottom banner, and 'Connecting to Peers' in the progress bar of each individual torrent.  

qbittorrent connects to DHT, but none of the trackers are working.  All 7 show as 'Not Working'

utorrent shows trackers as 'Connection Timed Out'

Disabling/re-enabling DHT does nothing. 

Uninstalling uTorrent and removing my settings and then reinstalling uTorrent does nothing (except annoy me by having to reset all of my settings).  

Under Options>Setup Guide it shows my port is not forwarded and says 'Port is not open (you are still able to download).'  -Obviously not true.  

Windows shows 2 critical updates were installed on the 27th, but uTorrent was working on the 28th.

Nothing else has changed between when uTorrent worked fine and when it stopped working that I am aware of.  I figure if this was due to an OS update or Router Firmware update, I wouldn't be the only one asking this right now since my router and OS aren't exactly unique.

uTorrent version: 3.4.5 (build 41712)

Windows 10 Pro 64bit (latest updates installed)

Core i5 with 12GB of RAM

Seemingly unrelated changes made: I changed a few of my browser security settings at around the same time things stopped working, but that really shouldn't matter.

I've also tried right clicking and running as administrator with no success.

Anyone have any suggestions?

Thanks in advance,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...