Jump to content

Beware, I have read Ultima's guide; this is a long post.


Recommended Posts

Alright… here's a long one for you guys. I've been digging through this site, as well as about a hundred others looking for a solution… but none have helped… so I'm finally resorting to asking for help… feels almost as awkward as stopping the car to ask for directions, right guys?

Anyways, here's the scoop: I steadily upload between 20 and 40 kB/s, but my download speeds only fluctuate between 20 and 30 or so!!! I am under the impression that although my internet connection might not be blazing along, the download speed should at least be higher than the upload?!?

I have thoroughly read all the guides and advice found here (and elsewhere), and so, without further ado, here are my results from Ultima's guide (with my comments in [square brackets], where applicable):

- Make 100% sure you read the setup guide properly and in its entirety

[More times than I care to count!]

- Set your firewall up properly, if applicable

- Select the correct upload speed in the Setup Guide

- Read the entire FAQ

- Search the forums for similar problems, using keywords and such

- Use the newest version of µTorrent

[i am using the WebUI Beta Version 1.6.1]

- Disable IP resolving in the Peers tab

- Try disabling UPnP

- Lower net.max_halfopen to 4

[Currently set to 4, but have tried settings anywhere from 4 to 60!]

- Patched TCPIP.sys and restarted computer after patching?

- Make sure you have a green network status light in the µTorrent status bar

- Try testing a torrent from OpenOffice.org or Ubuntu Linux?

[Herein is where the majority of my issue lies: I can achieve faster speeds on the OpenOffice

torrent, but not on any other torrents. I have tried private trackers as well as public ones

but it never makes a significant difference. I can see hundreds of peers, and have no

problem connecting to dozens of them, but then, nothing happens! Or, best case scenario,

one peer transfers to me at around 20 kB/s, and 2 or 3 others send 0.4 kB/s and nothing


- Try enabling Protocol Encryption?

- Made sure peer.lazy_bitfield is enabled?

- Check to make sure your ISP isn't listed here

[Mine is… but surely that doesn't mean that the answer is simply "too bad?"]

- If you are using a wireless Internet connection, then chances are, you will be permanently firewalled, and will not be able to forward your ports

[i am on a wireless connection, but other PC's hard-wired in my house have the same issue,

and furthermore, my ports are properly forwarded.]

- Windows 95/98 users should have their global maximum number of connections set lower than the value for the MaxConnections value in the Windows TCP/IP Registry Entries.

- Color of the network status light in µTorrent's status bar

[Always Green, all the time (more or less!)]

- What the port checker from the Speed Guide writes


- What the Speed Guide shows your settings to be

[Connection type: 512k, all settings as set by Speed Guide, with the exception of those listed


- Operating system installed (Windows XP, 2000, ME, 98, 95, NT? Something else?)

[Windows XP Home Edition, with SP2 installed a while ago.]

- Security software installed (firewall, antivirus, antispyware, antiadware)

[Windows XP Firewall, Windows Defender]

- Exact router model

[Router is a Linksys BEFW11S4]

- ISP being used

[Cogeco, (Burlington, Ontario, Canada)]

- Results obtained from the speed test for both download AND upload

[Repeatedly scores immediately just below the '640k' setting, so I have rounded down to the


Any advice anyone can offer would be greatly appreciated… and if the answer is something so simple no one can believe I overlooked, please feel free to flame me until the end of the internet… I may lose my pride, but at least my torrents will move!

Thanks in advance.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...