Jump to content

BT Homehub and utorrent - port forward problems


Recommended Posts

HI I was wondering if there was anyone out there who can help me solve my connection problem with u torrent and the bt homehub...I have seen several similar pleas for help out there, and can't seem to match my problem specifically!

I have XP, windows firewall (all the following is exactly the same with the firewall disabled), utorrent 1.6.1 and a bt home hub 6mb connection. I use avg virus and spyware protection, but no firewall with it. I have followed the steps for setting the utorrent port not to randomize, and opening this specified port on the bt homehub settings...however, my light in utorrent remains yellow or red, with speed less than 10kbps at best...!

I tried www.portforward.com to create a static ip address, but I dont seem to be able to set the right values as my connection fails immediately after I accepet the newly entered settings. Is this whats causing my connection trouble does anyone know, and if so/if not can anyone help me at all please!?Its driving me up the wall, as it does to all of us!

thanks for the help!

Link to comment
Share on other sites

I've just finished writing a small guide to forwarding a port/setting a static ip for the homehub, it may be of some help:

Okay, portforwarding for µTorrent and BT homehub:

First step: Static IP

Go to start>control panel>open "network connections">right click "local area connection">Properties. Like



Find Internet protocol (TCP/IP) under "this connection uses the following devices"


Click "properties"

Fill in you particulars similar to the following:



Click ok on TCP/IP properties and then ok in Local area connection properties.

Next step: Setting µTorrent

Click options>preferences


Select "connection" from the left panel and enter your port. Uncheck "enable UPnp

port mapping" and "randomize port each time µTorrent starts"


Click Ok

Next step: Setting up a port in the homehub

-Open your web browser and type into the address bar

-The username is admin and password is admin[/] as default

-Click "advanced" in the left hand panel

-Click "continue to advanced"

-Click "application sharing" from the LH panel

You should see this:


Click the blue writing that says "Click here to create it"

-Select "manual entry of port maps" and name it anything you like ;)

-Click "next"

-Enter your port as set in µTorrent lt should be similar to this:


Click "Add"

-Click "application sharing" from LH panel

-Select the service from the LH drop down list, like so:


-Select your computer from the other drop down list

-Click "Add"

And that should be it! Any feedback is appreciated!

Hope it helps :)

Link to comment
Share on other sites

thanks very much TBO, I now have a working static ip address as far as Im aware! internet connects fine! (Just a thought, does this new setting have any implicatoins for the other computers on my network? i.e do their seetings need changed?) I used the same settings as yourself, but with the DNS servers the other way round as thats what my settings say in the homehub preferences...

Utorrent still tells me that the port is not forwarded correctly tho!and the speeds remain very low still, and the light in utorrent is still the yellow exlamation mark...any further thoughts?

really appreciate the help, thanks!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...