Jump to content

Can't stay connected to peers


Recommended Posts


I just registered an account here due to a problem I'm having with peer connections.

What has been happening, only happens with torrents I create (using uTorrent for creation). The tracker(s) will report that everything is working and I will see peers, but I can''t stay connected to them. So, most of the time, it will say "0 of x peers connected", only connecting for a few seconds at a time every once and awhile. Some data will get transferred, with speed climbing, sometimes to 40kb/s or so and then dropping back down to 0kb/s, with connected peers going back to 0 again.

This does not happen at all with other peoples torrents, even on the same tracker(s). With those, my download speeds are excellent, getting 200-300KB/s sometimes, with upload speed reaching 80KB/s + (these are max rates I've seen, not average). Even when speed is slower, it is always at least steady, unlike with the ones I create and attempt to seed.

This problem is not uTorrent specific it seems, as I tested to see if I had any better luck with several other clients to no avail. But, I posted this here as uTorrent is the client I prefer to use and I honestly don't know of a better place to ask for help about this.

I have tried everything I can think of, max speeds, max peers, max global and every other general option in uTorrent as well as changing ports. I have tried so many different ports, I lose count. Ports are open on the router, the windows firewall, etc.. port test comes back as OK every time and I see no difference.

This is very odd, because, as I said, I have no problems with torrents that others are seeding.

I think I covered about everything, but of course, if there's any info I left out, feel free to ask.

I'm not quite to the point of banging my head on the desk, but not far from ;) So, any help on this will be greatly appreciated!


Additional info:

-I have a cable connection.. very fast and forgive me for not knowing exactly, but I have seen transfers from FTP sites over 900kb/sec, if that helps.

-I am using a Linksys NR041 wired router (firmware Version 1.2 Release 06) -- not sure how that info can help, but not being sure about this problem is why I am posting :)

-I have used cFosSpeed, but it makes no difference with this problem whether it's enabled or disabled..

-Just windows firewall here... Windows 2003 server edition

-uTorrent settings, I have adjusted many ways. Currently, as I'm trying to figure this problem, I am using the default settings for xx/384, with encryption enabled. I have tried forced as well as none. This doesn't help.

I can still connect no prob right now to others seeded torrents.

Again, any help is appreciated.


Did I post this in the right place? Did I provide enough information? I know patience is an admirable virtue... but, any ideas?

Link to comment
Share on other sites

I have tried enabling initial seeding.. but it seems worse with this. Initial seeding would be the same as super-seed? So, no duplicate bytes will be transferred?

If so, I think since there is trouble staying connected to peers, that would make it worse and certainly seems to.

But, I saw in another post here (I should reference it, but I can't find the post now, sorry), that I should disable DHT and not forward UDP from the router. I tried this (disabling DHT on the problem task only) and after a couple mins, it began transferring steadily. I think it's too early to say this has solved it, as I have seen it go steady for a bit, thinking it was fine, then dropping again.

But, maybe it's a step in the right direction... is this a typical problem with Linksys routers? it is a NR041, wired router...

Link to comment
Share on other sites

lol yeah, I was asking if super seeding was enabled, as it would *cause* these types of behaviors. And yeah, it is super seeding (renamed so that n00bs don't enable it for no reason).

Indeed, connection overloading is another possible cause. Try selecting an even lower setting in the Speed Guide. I'm not sure about how NR041s behave. Try disabling IP resolving in the Peers tab and lowering net.max_halfopen to 4 (or thereabouts) in Preferences > Advanced while you're at it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...