Jump to content

D-Link DI-524, Tried Everything Possible...Port Will Not Open!


Recommended Posts

Hello Everyone, this is my first post. I thank anyone that replies and helps me out with finding a solution to this annoying problem. Here are my specs:

O/S: Windows XP SP2

Hardware: D-Link DI-524 rev. A, Motorola SB5100 Cable Modem, Linksys SPA2102-R VoIP

Firewalls: NAT From Router, Zone Alarm Pro, Windows XP Firewall (Disabled), uTorrent 1.6.1., BitComet .89


For some reason, every time that I do a port check to see if it is open, it fails. I use the uTorrent Port test and I use http://www.canyouseeme.org/ and both fail. I'm using both uTorrent and BitComet to see what kind of speeds I can get and I'm always getting green connections or connections that are waiting to connect, which sometimes can take forever (meaning days, even when there are a lot of seeders and leechers). There are no remote connections to peers, there are only Local and NAT Transversal connections. Occasionally I will get connections with 40-50kb/s, but most of the time I'm getting from 2-10kb/s. I never get anything extraordinary, maybe in a blue moon I'll be dling at 180kb/s, but that will be only through a local connection and it will probably last for like 1 min at most.


At first I had the VoIP(internet) connected to the Modem(internet) and VoIP(ethernet) connected to the Router(WAN Port). This would allow me to go online and download, but port will never be opened. I can't log into the VoIP box because the stupid company is a Chinese company and I can't speak, I would need my parents to ask for a bunch of crap. They set some password when trying to log into the VoIP box. So I can't open the port. So what I did was I switched the wiring to VoIP(internet) connected to the Router(LAN Port 2) and Router(WAN) connected to the modem(internet). This way my data goes through the router and with the router having the port forwarding I got a opened port. And I was able to connect to remote and local and NAT Transverse connections. Then I did something, I am not sure what I did! Maybe restarted my PC, changed a setting or whatever, but now my port is closed again.

Things That I Have Done:

First thing I did was to see if my cable modem had a built in firewall or if it was zone alarm. So I hooked up to my modem directly. Note: I have Zone Alarm UDP & TCP Ports Allowed For the port that is listening in the two Torrent Clients. Anyway After hooking to my modem directly I would do the port check through the methods explained in the situations section and I would get PASS and I can see the port. So my modem is good and Zone Alarm is good as well. I was downloading with those settings and with the direct connection it was smooth, everything was nice. However, I have 4 PC's and a laptop that need to be online so I have to have a router. Anyway, I reconnected to the wiring mentioned above and I used that portforward.com website over and over to see if I did it exactly and have set up my virtual server with the correct values. I have setup a correct static IP. Still, no luck. DMZ on router is disabled, DHT is disabled on software is disabled, UnUP is disabled on router and software and still nothing. I'm able to download, but I can only connect to local and NAT transverse peers. However, there was a time when I fiddled around with my hardware my port was closed when I ran the test, however I could connect to remote peers along with the local and NAT transverse. This was weird.

At This Point:

I'm back to the setting where I can only connect to Local and NAT Transverse peers, I have my static IP correct and Port Forwarding correct. The port is not opened. I am in the wiring where I am going through the router, not the VoIP box. The VoIP box is connected to the router so the telephone doesn't need that port opened. Does anyone know what I can do, or can say something to spark a light so that I can try something new? Please help me this is so frustrating! Thanks to whoever that replies. I hope I gave all the information that would be needed in order to help solve this problem. Thanks again!


I am using two different listening ports for BitComet & uTorrent and both ports are forwarded, still no success.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...