Jump to content

Slow upload speeds


Recommended Posts

I am using Bell High Speed, Windows XP SP2, SpeedStream 5200, uTorrent 1.7.5

I have been using Utorrent for a long time and it has been working fine with upload speeds upto 70 kB/s. But recently, for some reason, the upload speeds never go pass 3kb/s no matter what I am downloading. The speed guide shows that I should have upload rate pass 70 kB/s and I passed the port forwarding test.

I have UPnp port mapping enabled

Added to Windows Firewall exceptions

Protocol encryption enabled

I don't know what else I can try

Please help!!

Link to comment
Share on other sites

If you "passed the port forwarding test", as you saying, you're no longer need for UPnP port mapping (in my case, both that µTorrent's options - "Enable UPnP port mapping" and "Enable NAT-PMP port mapping" - is disabled; note that I've my modem's web based utility where I'd setting up "NAT Port Mapping" feature to enabled state; because µTorrent won't work without this, but still working with yourself disabled "Enable NAT-PMP port mapping" option; ...some info for you). I'm not really sure, but I think that you should, as example, for some security reasons, disable this µTorrent option. I mean "Enable UPnP port mapping". And don't forget about disabling next two potentially bugging services, of course, only if this services still working on your system --> "Universal Plug and Play Device Host" and "SSDP Discovery Service". I'm currently "working", in other words, "downloading and seeding" without theys and all going like a charm - classy and fun. Just go to "Control Panel" -> "Administrative Tools" -> "Services" to find this services, if you're don't know about this way - first, stop them's and second, reconfigure it's to "disabled" state. That's all. And how about typical situation with trojans and viruses on your machine?

Okey, here's some tips for you, if they can helps:

1. Guessing that µTorrent very, very sensitive for, let me say, "the strategy" of his both "download" and "upload" limitations. And all his work alghorithms, as I think, "playing" around this trick...

I'm talking right about...take a look at the picture below


As you can see, I'd changed download/upload speeds to they's maximum values. All - for the reaching a limitations. So, that's my advice and recommendation: if you really want maximize your downloads and uploads, no matter, what's your modem connection in fact, you should "right clicking" on the borders you seeing and you should increasing speed limitations to they maximum values. Don't leave "limitation" option in "unlimited" state. You can also make this with all your downloads and uploads you have. Just focus on the main window and press Ctrl + A for selecting all you torrents. And then, right click on those "all selection" and find menu item named as "Bandwidth Allocation". Within that menu item you'll see some another two menu items - "Set Download Limit" and "Set Upload Limit". That's exactly what we need. Try do not run multiple tasks in same time in that mode, don't share your overall speed between them's. And finally, I know that you know about all I've saying to you...Joke...

2. If it's not critical for you, try to disable "DHT Network", "DHT for new torrents" and "Local Peer Discovery" in "Preferences"/"BitTorrent". You know where is it.

3. (...Little offtop...) If you've machine with modern and latest microprocessor and more RAM, you can also dramatically (who know, maybe I mistake) decrease number of the hard disk's reads/writes that µTorrent made by changing some couple µTorrent options like a "diskio.coalesce_writes" ("Advanced" tab in the "Preferences"), "Write out untouched blocks every 2 minutes" ("Disk Cache" tab) and so on. Check µTorrent's guides and documentations, if you've still not checked them.


Have a nice day...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...