Jump to content

Tokens broke my webui!


Recommended Posts

I think this issues has come up in other posts, but I thought I'd make a new post to get a bit more attention since i think its a fairly big issue.

My webui (0.360) was working fine until I tried upgrading to 0.361 this evening and now I get the following when i try and access the webui:


and i get the following error in my error console:

Error: uncaught exception: [Exception... "Cannot convert WrappedNative to function" nsresult: "0x8057000d (NS_ERROR_XPC_CANT_CONVERT_WN_TO_FUN)" location: "JS frame :: :: <TOP_LEVEL> :: line 1" data: no]

I then tried reverting to 0.360 but I think the token system has been added to it as well (I re-downloaded, I wasn't smart enough to make a backup), because I got the exact same results.

I'll submit a bug report on Trak, and hopefully this gets fixed, but in the meantime could someone post a link to a pre-token webui.zip that I could use? security isn't my biggest concern.

Edit: forgot system details.

Browsers: FF3.03, IE8(beta 2), IE7

uTorrent: 1.8 (11813)

People with similar issues have been told to upgrade to the newest utorrent, which I tried to do, but links to the latest betas are broken, so I have the latest available version.

Link to comment
Share on other sites

Don't bother submitting a ticket on Trac, as this isn't a bug with WebUI itself. This is more likely a support issue (and has nothing to do with the token auth system either).

Are you behind a proxy of any sort? Have you tried the "legacy" version of WebUI as linked in the v0.361 announcement thread?

Edit: And in what way are the current betas "broken"?

Link to comment
Share on other sites

I am not behind any proxy(same lan and I get the same problem on the machine running uTorrent using, and I have not tried the legacy version. I'll try it right now and see what happens.

I believe this to be a problem with the webui itself since it worked perfectly with an older version of 0.360, but has broken with 0.361 and the currently served version of 0.360

I've added some system information to my first post

Edit: Sorry I meant to say the links are broken. At least the ones in the announcement thread are.

Link to comment
Share on other sites

1.8.1 is stable (no longer a beta).

1. Disable webui.token_auth

2. http://localhost:8080/gui/?action=setsetting&s=webui.cookie&v={}

3. Enable webui.token_auth

4. Ctrl+F5 in Firefox

If that doesn't help...

1. Exit µTorrent

2. Backup your settings.dat from Start > Run > %appdata%\uTorrent

3. Delete settings.dat and settings.dat.old from %appdata%\uTorrent

4. Restart µTorrent and reconfigure

5. Ctrl+F5 in Firefox

If that helps, please upload your settings.dat for analysis. Thanks!

Link to comment
Share on other sites

Well It's working...

I thought i had figured out the problem but when i tried to reproduce it I was unable to...

What I did notice, however, was that when it was not working, the webui.zip was corrupted (when i tried to open it with winrar I received errors, and having now opened it when it was working i see that some directories were missing). When i first got it to work, the only thing i had changed was downloading to desktop and copying it into the folder instead of specifying the download directory directly. In both cases I overwrote the file. However this does not seem to have been the cause since i cannot break it again by simply downloading directly (and yes utorrent was closed during all attempts whenit was corrupted).

What this leads me to believe is that the version that I had downloaded was actually corrupted to begin with, but I find that hard to believe... unless you use some kind of automated build system and it was half way through a build? (how long does it take to make a zip file of that size though?)

Unfortunately I don't think I've shed any light on this issue, so to those who are experiencing the same problem... my recommendation is to wait a half an hour or so and then try to re-download the zip.

Edit: Also a thanks to Ultima for the prompt replies! :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...