Jump to content

No incoming connections


Recommended Posts

First of all thank you for reading my post.

I have been using uTorrent for some time now. I have noticed a problem with both uTorrent 1.8 and 1.8.1 that seems to intermittently prevent my client from receiving incoming connections. I have the yellow exclamation icon; however, when I use the uTorrent port checker via the speed test guide, the uTorrent website indicates that the port (10315) is open. 3rd-party port checking websites also indicate an open port.

Logger shows the following errors:

[time] <peerip:port>: Disconnect: Peer error: offline (timed out)

[time] <peerip:port>: Disconnect: Connection closed

[time] Incoming connection from <peerip:port>

[time] <peerip:port>: [clientinfo]: Encrypted handshake completed

[time] <peerip:port>: [clientinfo]: Disconnect: Connection closed

The incoming connection ports seem to be random, instead of the fixed port I have mapped. I'm not sure if that's significant. The outgoing connections ports are always random and I believe that's normal. Prior to upgrading to version 1.8, I was using version 1.7.7 (which worked normally). I then downgraded to version 1.6 (after uninstalling utorrent, deleting directories, etc...) which I used with great results until version 1.8.1 was out of beta. I then clean installed uTorrent again, hoping the bug from 1.8 had been addressed; uTorrent worked normally for several weeks, then I started getting the errors noted above, along with the exclamation icon.

My anti-virus/firewall is Live OneCare. My windows version is XP Pro SP3 (with all available updates). I have manually mapped the port withing OneCare's firewall settings, and have also mapped the port manual on my Apple Airport Extreme (draft-n) router. There are currently no entries for uTorrent within OneCare's automatic firewall settings, as the port has been manually opened. None of this has changed between the versions of uTorrent I have tried. My incoming connections are limited to 4, 8 half-open connections, 100 global connections, etc...

Any ideas?

EDIT #1: After extensive testing, it appears that through the upgrades some preferences for individual torrents have been retained; such as upload bandwidth limitations. I have since upgraded back to 1.8.1 and I seem to have all of my bandwidth back; however, I still have the no incoming connections icon, even though I am uploading at the limit of my connection (200Kbps+). Only one torrent appears to be active, although several appear to have enough peers to warrant me seeding. Not sure if this is related to the fact that I have forced outgoing encryption but still allow legacy incoming.

EDIT #2: Download speeds seem reasonable as well (tested w/ Slackware DVD torrent); multiple torrents are now seeding with multiple peers connected. Still have the mysterious "No incoming connections" icon and errors.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...