Jump to content

Windows 7 and UTorrent


Recommended Posts

ok, have been having major trouble with UTorrent and Windows 7 Ultimate x64 - but am unsure if it is the OS or just the Compatibility issue.

loaded several torrents in initially, ranging in size from 30 - 200 mb (single and Multiple file)- downloaded fine. Next tried several larger files, ranging from 500 mb to 10 gb (10 gig was started at the initially as well). 1 smaller torrent finished, several got to 99.9% and then lost all data. the 10 gig file, which was at 45% by this stage would download and then lose all data back to 45%. also when the files had done this it would also stall the exit of the program, and was even unable to close through Task Manager. it would also halt the automatic shutdown of my PC, luckly though when i even attempeted to close the Program, it would stop using bandwidth.

Started using Vuse to try to complete, but found the interface BS and memory usage CARP :P, managed to get a couple finished though. Have come back to uTorrent and tried Compatibility mode (Vista and XP) over the last couple of days to no avail. Did find that the torrent would be saying that it was 90%+ complete when the file tab was saying 1.2 gig file was 86%ish and a 216 byte file was 100%. didn't quite add up to me, so decided to stop torrent and force re-check, which bought completed % into about 87-88% for both - started again and the Torrent % was counting up much quicker than the File %. kept re-checking and eventually got the file finished, but can't do this all the time

also, had a prob when i woke up this morning that although shceduler had stopped my DL's, Utorrent was using 1.2 GB of RAM. i know that this is not normal

Basically all i want to know is is this a uTorrent issue, W7 issue, mixed issue or have i screwed something up. i usually run utorrent OOTB stock (have been editing setting to see if things will change), changing port settings to match the router.

Any replies, comments and help would be greatly appreciated. Any questions, just post here, i'll be back to check soonish.


ok - have been playing for anyone interested - and have come up with some ways around some of the problems. Basically, the best thing to do is keep utorrent open untill you DL's are finished, but i imagine most, like me, keep adding and adding - so never really finished, are we.

1. You MUST STOP ALL torrent file activity before you close utorrent (also PLEASE NOTE NO.2) - otherwise the torrent program will continue to run in the background and will be unable to end process in task manager

2. you MUST "FORCE RE-CHECK" prior to closing utorrent otherwise large chunks of current progress, if not all since last up, will be lost.

3. Memory Usage thing i think is a W7 thing. was trying unsucsessfully to close utorrent the other night and had a bit of fun when i changed "UAC Virtualisation" in Task Manager (don't know what it is, but hey). Should have checked it prior to doing because RAM usage gradually (within about 3 minutes) climbed from 130ish MB (i think this is still excessive for utorrent though) to around 1.2GB. as i messed around further, it began to climb further - had to kill system.

still have not figured out progress thing, will se what happens when some of my larger files start to come closer to the end (unfortunately have poor speed at the mo, my ISP is fairly small in the grand scheme of things and is just getting round to leasing new International lines).

Have currently, since last post had 2 200MB-500MB torrents of mutiple files finish on their own, and 2 over 2 GB torrents (1 iso and one split RAR) finish of their own accord too. Had system up the whole time, just noticed these other *hopefully* fixes when i started taking my lappy away (turning it off and on, and losing chunks of DL's :( )

I have been using scheduler as of late (as i get unlimited bandwidth between 1 am and 7 am) because was have trouble with shutdown (had auto start and auto shutdown on Vista sidebar and worked fine, but not on 7) . Must be the way 7 deals with closing programs... i dunno, not a programmer.

Good luck to anyone out there that has this problem, hope your are having better luck than me.

P.S. I am using Windows 7 64-bit (6.1, build 7000) - with all current updates - if this helps anyone solve problems/find fixes

*EDIT 2*

Still no luck with the DL's - Sometimes they work, somtimes they don't had about 7 "2 gig" files finish of their own accord (yay, internet is a bit faster again). Prog still crashes sometimes, but now it seems that it only crashes when provoked (naughty boy - stop playing with it).

My NEW reccomendation out there to anyone interested (though it seems not many are) is to do ALL FUNCTIONS INDIVIDUALLY. stop downloads individually, re-check individually, do not use open file location, as this opens another instance of "explorer", which can clog system.

Windows 7 x64 problems are related to the "dllhost.exe" service (well, a theory i have, just guessing, but may be a place for programmers to look), as well as the .net framework.

dllhost.exe goes absolutly nuts when i go into a folder of .m2ts files i have transcoded from .mkv, trying to sort out thumbs for the files, whereas the files from my sony hd handcam just brings up the thumbs. i was looking to see if there was a solution, but only found out that this is all related to the way w7 and .net work together. oh well, guess thats what i get for using a beta (although they are the best VCR's ever :P )

Good luck to all Torrenters out there and also anyone whom is on W7. Loving it, but the probs are big. Can't wait till the finished product.

Link to comment
Share on other sites

  • 5 weeks later...

I'm using windows 7 beta. My Utorrent is downloading, but when I check if my port is forwarded correctly theres always an error. Also when I check with Portchecker it says my port is unaccessable. I left it that way coz the download seems to be working anyway. But I just thought the download speed might get faster if those errors were corrected. Does anyone have ideas on this... In my previous system installations I had experienced successful port setups and also unsuccessful ones whick I cant understand why sometimes an error just occurs. Hope somebody can enlighten me on this matter. Thanks in advance.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...