Jump to content

Is uTorrent part file size limited to 2GB?


Recommended Posts

I'm downloading a really huge torrent (about 300GB), and I found it always raise a data error after some time. Force re-check take no effect; It raise the error again after check finished. The only way I found that can work is delete the uTorrent generated part file (named ~uTorrentPartFile_xxxxxxx.dat) and resume download.

After some times of error, I noticed it seemed to always happen after the part file grow to more than 2GB. So I guess it may be because uTorrent use an integer of 32bit to hold the part file size?

Link to comment
Share on other sites

Well, a 32-bit unsigned integer allows up to ~4GB, not 2GB, so even if a 32-bit integer were being used to address data in the file, it shouldn't be screwing up at 2GB (to begin with, µTorrent can already handle files larger than 4GB anyway).

Can you tell us specifically what error is shown? Does anything interesting appear in the Logger tab (with misc errors logged)?

Edit: And FWIW, I've had torrent jobs where the partfile bloated up to 2.21GB, and I didn't experience any such problems then. That doesn't necessarily mean there is no such limitation (there could always have been a change/regression between the time I had a 2.21GB partfile and now), but I seriously doubt it.

Switeck has also suggested that it could be a filesystem issue. Now, I tend to doubt that as well, but it never hurts to tell us what filesystem your drive is using too.

Link to comment
Share on other sites

All of my disks are NTFS partitions. I've saved some files with size over 4GB without problem, so I don't think it is caused by the file system.

The log tell me a data error happened. I could not remember its exact description, but I've watched it two or three times and don't get anything useful from it. Now the part file is about 900MB and no error until this time. I'll report the log if the problem raise again.


Now the error raise again, log as following:

[2009-11-16 19:35:07] IO Error:13 line:1817 align:-99 pos:83657395436 count:357140 actual:-99

The part file size is 2,168,413,188 (about 2.01GB)

Link to comment
Share on other sites

  • 1 month later...

I have the very same problem. I download 2 too big torrents with lots of files. When part file on each torrent reaches a bit over 2GB the error occurs: "invalid download state, try resuming". Re-hash wiil result another error right after starting. Another re-hash oddly completes fine, but shortly after starting download it all repeats again. I've tried everything and got this is definitely because of partfile size.

Dunno, maybe this is operating system or filesystem related issue, but hope it will be fixed as soon as possible. I'm using uTorrent 2.0 Beta on Windows XP 32-bit with NTFS of 4-byte cluster (tried 1-byte too). Maybe 64-bit system users don't have this problem, I'll install x64 Windows and report if problem remains.


Well, I've installed 64-bit Windows 7, installed uTorrent and resumed download from this point. There is no changes, this error happens again. Rehashing -> Start and very soon when very first piece is downloaded (pieces are 16Mb), it reports error: "Wrong data". Part file is about 2 112 973 Kb (both torrents have different exact size, however, they are very close).

So this is not the filesystem or OS issue, therefore this is a bug or limitation in uTorrent. Hope it will be fixed as soon as possible.

Link to comment
Share on other sites

  • 2 years later...
  • 5 months later...


This topic is now archived and is closed to further replies.

  • Create New...