Jump to content

Ports not opening in Windows 7


Recommended Posts

Hey, I cant get utorrent to work properly in windows 7 - the program gives me a red light, and the port checker tells me that my chosen port isnt open.

The thing is, i have another computer running Vista in the same network, that runs utorrent perfectly. I tried the same config on the win 7 machine, but it keeps accusing the port to be closed.

Some notes:

Port is forwarded in the router

I am using Comodo Firewall, also properly forwarded. Actually, i did try uninstalling Comodo, but the same thing happens without it.

Windows built-in firewall is disabled

Yes, i read and tried everything in the stickies.

I'm at a loss here, anyone got any ideas? Thanks in advance


Managed to solve it!

Turns out, when i forwarded the port in the modem/router, i did it for the local ip range to cover both computers. The router can display the NAT translations, and, for some obscure reason, it was redirecting the packets to random unused local ip numbers....weird. I just set up a different port than the other pc and forwarded for this ip only, and voila - works perfect.

Just for the record, the modem/router is a Dslink 200u/e.

It seems to have a "burn" problem. "Burn it up and get a new one".

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...