Jump to content

Strange thing when skipping files


Recommended Posts

I started a download from a public site (Torrentspy), it is an image of a DVD, the total torrent size is 2.86GB. I usually don't download the samples or sample directories of videos, I unselect them from the download window and the files show as "skip" in the files window of course. This has worked without any trouble in the past, must of the time downloading TV episodes that are usually 350MB, but with this DVD torrent something strange has happened. µT said that the download was completed but several of my files were still using the !ut extension.

I ran several times the "Force re-check" command and always came without errors. I assumed that there was a fail in the renaming of the files and renamed them manually deleting the !ut extension but WinRAR showed corruption errors everywhere. I thought that somehow the files got corrupted and deleted the ones that were showing the !ut extension and restarted the torrent, with great surprise that after some hours µT showed the "download is completed" alert but the files were still using the !ut extension.

I almost deleted the torrent completely assuming that the uploader had fucked it up but it occurred to me to activate the skipped file, the sample. After some minutes µT reported the successful download and this time everything was ok, there was no corruption in the RARs and I could extract them without any trouble.

I think that somehow µT screwed up the buffers of this torrent and was not flushing correctly some parts of these files due to the skipped one. Have you seen something like this before? Is this a bug?

Thanks for your opinions.

Link to comment
Share on other sites

I've seen problems with extracting archives in a torrent where I'd skipped a file(s) as well. Not all the time, but it has happened and was always one where I'd skipped something in the torrent. Both where I'd skip a file and downloaded the rest all at once or downloaded just a sample for example and after viewing it downloaded the rest at that time. This has only happened twice though and may not be related to the file skipping, it may just have been coincidence.

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...