Jump to content

Major issues (some NAS related)


Recommended Posts

I've recently purchased a high-end Qnap NAS and have set Utorrent to save new torrent data to it. However, I've run into a number of strange bugs related to the use of my NAS.

1. Saving directly to the NAS causes Utorrent to behave very slowly and I only see barely 1MB/s downloading when I am capable of over 12. I discovered that I could work around this issue by choosing to save data to my HDD and then have Utorrent to move the data to my NAS. Generally, it performs this task quite well as I reach speeds exceeding 90MB/s when Utorrent "moves" over my internal network.

What is going on that would cause Utorrent to behave so slowly if I just make my primary save directory on the NAS? It's obviously able to seed from this location once it moves the data over. I've tried pre-allocating files and this too fails. I just want to make my primary save directory on the NAS without having to MOVE files. My network is 1Gbps, so it's not congestion.

2. Deleting Torrent plus Data from a NAS directory doesn't work correctly. The torrent will delete from the list within Utorrent, but the data in the NAS directory is still there. This prevents me from downloading an updated or revised torrent until I physically go into the directory and delete the old containing folder.

3. Checking a torrent in a NAS directory can (but does not usually) lead to constant "Failed to write to disk" errors on some torrents. New torrents have never given this error and I have downloaded hundreds of files to verify this point. It seems that this may be related to special characters in file names.

4. And this is MAJOR. When downloading files, Utorrent rarely writes out to disk if the application window is not open. I've tried this on 4 machines and it does the same thing on every one. The cache will fill up and hang until such time as I open the application window and then it decides to write to disk. Note that this issue is not a NAS-related bug like my previous issues. This happens on my machines not connected to my NAS.

5. Force rechecking can cause utorrent to become permanently unresponsive and/or crash.

In closing, I really love Utorrent and it's one of the few bit-torrent applications that allows me to make use of my NAS for torrenting. I sincerely hope that the developers work to increase support for NAS and I would be willing to share my use and crash data to help.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...