Jump to content

"Connection timed out"


Recommended Posts

Good day,


I noticed a couple of posts handling the topic: "connection timed out". 


Since those topics covered different kinds of situations which I didn't seem to relate to, I made a new topic and I was hoping for an answer. I will provide all the information I guess is useful and more information can be requested to help deal with the problem.


My problem is as follow:


  • DHT not working (same as most situations)
  • Trackers are all showing: connection timed out

There is one but, one tracker does not. It's a http:// tracker instead of an udp:// tracker. This is the only download that currently works. Some udp trackers, often used, like publichd, are even showing: no such host is known.


This caused the problem: searching for peers at all but one torrent.


I only have downloads in my list that are released by well-known and respected RGs, never having any problems with them. They even host their own tracker. Not once have I had a problem, but after the update of 3.4.2 I do seem to get this problem.


Now, I tried to downgrade utorrent, but this didn't help, so I need a solution that doesn't involve updates.


Additional information:


Windows 7 Ultimate x64

Running Malwarebytes and Security Essentials but eventually dropping guard on utorrent, so utorrent has a free go (I only download what I know will not be tempered with)

Running uTorrent 2.2.1 and 3.4.2 (Latest)




  • Port forwarded: UPnP, NAT-PMP enabled
  • Enabled DHT
  • Enabled Local Peer (working)
  • Enabled uTP (working)
  • Enabled UDP support
  • Enabled Peer Exchange (working)
  • Protocol Encryption Enabled (was disabled but changing to enabled didn't do anything)
  • No additional changes to settings

More required information can be gathered.



Link to comment
Share on other sites

Solutions I do not have for those that encounter this problem. I solved it by completely removing utorrent, redownloading everything in the list and removing essentials. Don't know what did the trick but something did 

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...