Jump to content

DHT: Waiting to Login / "Connecting to Peers" HELP


Recommended Posts

For the past week any torrent I download is stuck on "Connecting to Peers". I have gone through countless threads and tried everything, and I cannot get it to work.


Some Details:

I have Comcast.

I have not had trouble with this until recently and no changes to my network have been made.

I am downloading the Torrent via magnet link.

Torrent has 100+ leechers & 900+ seeders

I do not have antivirus.

Windows Firewall has Utorrent incoming and outgoing allowed (TCP & UDP)

I do not use a proxy.

Slackware torrents do work.

I have Windows 8.1

I have a wired connection

I do not have Peerblock or anything else like it


What I've Tried:

Deleting dht.dat from %appdata%

Uninstalling & Reinstalling

Enabling (& then disabling) random ports

Updating trackers

DHT, Peer Discovery & Peer Exchange are allowed

Deleting resume.dat

Deleting firewall exception & readding

Turning off firewall altogether

Double checking that I did not have remnants of anti-virus

Resetting router

Everything on the DHT troublshooting page

Did a network test in the setup guide and it said network was fine

Enabled protocol encryption

Everything else on this page


I have included a screenshot of the trackers tab. After a minute or so, all that information will disappear and all info in all tabs will be blank. I am at a complete loss as to what the issue is, and need some serious help. I need certain software for work temporarily and I need this to be fixed :( Please help!


Link to comment
Share on other sites

  • 2 weeks later...

Having the exact same issue and can't connect to trackers either. I know the torrents I am trying to download are good and slackware torrents seem to work just fine. I have read in other posts on this forum that it is probably an issue with my ISP. If that's the case, how do I go about fixing it?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...