Jump to content

Stuck at "Connecting to Peers"


Recommended Posts

This is a very common problem, I see. I have tried the slack torrents, and they work, but I realized the trackers weren't working. They would just say "Connection timed out."


I run Windows 7, and I use Malwarebytes for an anti-virus. However, it has excluded all of uTorrent's normal "virus" IP's.


Is there anything I can do?

Link to comment
Share on other sites

  • 3 weeks later...
Hi I have the same problem.


Do you use Peerblock?


I use Peerblock 1.2 and found that if I disable it most of the UDP trackers will work, though there are a few that still don't update.


By a tedious process of elimination,disabling lists one at a time, I discovered two lists which were blocking trackers (sorry I can't remember the names, I just deleted them - The name was just an URL with a lot of letters after:


uTorrent's own IP blocklist didn't have any effect so I presume it's ok.


Hope this helps. If you're using Peerblock, just try running uTorrent without Peerblock for a few minutes and see if it helps.



It is still blocking some trackers so there must be another entry in one of the other lists

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...