FreeBsd

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About FreeBsd

  • Rank
    Newbie
  1. FreeBSD 8.2 (gentoo-stage3) + Win7/64 (IE9) + utorrent-server-3.0-25053 WORKING! Problems on FreeBSD Error: ELF interpreter /lib/ld-linux.so.2 not found Solution: ln -s /usr/local/gentoo-stage3/lib/ld-linux.so.2 /lib/ld-linux.so.2 Error: missing libssl.so.0.9.8 and libcrypto.so.0.9.8 (this is standard error ) Solution: cd /usr/local/gentoo-stage3/usr/lib ln -s /usr/local/gentoo-stage3/usr/lib/libssl.so libssl.so.0.9.8 ln -s /usr/local/gentoo-stage3/usr/lib/libcrypto.so libcrypto.so.0.9.8 Error: missing other libs Solution: export LD_LIBRARY_PATH=/usr/local/gentoo-stage3/usr/lib:/usr/local/gentoo-stage3/lib Error: /etc/host.conf: line 2: bad command `hosts' /etc/host.conf: line 3: bad command `dns' Solution: export RESOLV_HOST_CONF=/usr/local/gentoo-stage3/etc/host.conf Probably, problems with utserver + su Problems on IE9: Preferences -> missing buttons OK, Cancel, Apply
  2. @mcdonald Tested. No, this is not my fault... This does not work at all with paths like this: dir_active:/mnt/utserver/incoming/ dir_completed:/mnt/O/ dir_torrent_files:/mnt/utserver/torrentfiles/ dir_completed_torrents: /mnt/utserver/torrentfiles-done/ dir_temp_files:/mnt/utserver/incomplete/ dir_autoload:/mnt/utserver/autoload/ dir_request:/mnt/utserver/request/ This is my small donation for project : //#include <tchar.h> void AddSlashIfNeeded(wchar_t * s) { int i=_tcslen(s); if(0==i) { _tcscpy(s,_T("/")); } else { if('/' != s[i-1])_tcscat(s,_T("/")); } }
  3. @mcdonald NO. Looks like it is my fault. My justification: there no any ending slashes in uTorrent config... And everything else works (FileTorrent,Magnet). Thank you!
  4. For FreeBSD: Adding torrents: From file: OK. From URL: Torrent File: NOT WORKING Magnet File: OK It can download only, when torrent has single file. If torrent has multiple files, it ends with error: Error opening "/mnt/utserver/incoming/xxxx.xxx": I can't set in Preferences->Drectories: Append the torrent's label Move .torrent for finished jobs to: Graph is OK on Chrome (not on IE9). As daemon (rc.d) must be started with SU (as common user): ${SU} -m ${TORRENT_USER} -c "${UTSERVER} -configfile ${CONFIGFILE} -logfile ${LOGFILE} -settingspath ${SETTINGSPATH} -daemon 1>/var/tmp/utorrent-start.txt 2>&1" &
  5. Configutation : FreeBSD7.1/32 /etc/rc.conf: linux_enable="YES" /etc/sysctl.conf: compat.linux.osrelease=2.6.16 Linux emulator: linux_base-gentoo-stage3-20110118 The cause: in linux_base-gentoo-stage3-20110118 are only newer libraries: libssl.so.1.0.0 libcrypto.so.1.0.0 So, I do patches: /usr/compat/linux/usr/lib ln -s libssl.so.1.0.0 libssl.so.0.9.8 ln -s libcrypto.so.1.0.0 libcrypto.so.0.9.8 / This issue was solved, but is next: Can't create pid file '/var/tmp/utserver.pid': 30 ????? Can't create pid file '/var/tmp/utserver.pid': 30 ????? This is strange, because in the previous version was OK. The solution - removal of "-pidfile ${PIDFILE}" Configuration of utserver.conf: Important: preferred_interface must be set! (Otherwise, many errors)l ogmask: 0xFFFFFFFF Directories: dir_active: /mnt/utserver/incoming dir_completed: /mnt/O dir_torrent_files: /mnt/utserver/torrentfiles dir_completed_torrents: /mnt/utserver/torrentfiles-done dir_temp_files: /mnt/utserver/incomplete dir_autoload: /mnt/utserver/autoload dir_autoload_delete: 1 General comments: The effect of any error in file utserver.conf is - data from the file are not read. It looks like the file settings.dat has higher priority, than utserver.conf . Bad settings from settings.dat override good setting from utserver.conf (from previous start, with errors in utserver.conf ) Solution: removing files: settings.dat.old and settings.dat PC: Windows7/64 + IE9 In tab [speed] graph is working, but is invisible. General comment: Graph is only a toy, tab [Peers] would be much more useful!
  6. Working in FreeBSD last pid: 1053; load averages: 0.00, 0.00, 0.00 up 0+01:01:53 20:56:36 32 processes: 1 running, 31 sleeping CPU: 0.0% user, 0.0% nice, 1.5% system, 0.4% interrupt, 98.1% idle Mem: 15M Active, 108M Inact, 68M Wired, 20K Cache, 56M Buf, 265M Free Swap: PID USERNAME THR PRI NICE SIZE RES STATE TIME WCPU COMMAND 972 root 1 44 0 201M 7224K select 0:16 0.00% utserver 970 root 1 0 0 201M 7224K linuxf 0:03 0.00% utserver 875 root 1 44 0 5412K 2580K select 0:02 0.00% telnetd 969 root 1 0 0 201M 7224K linuxf 0:01 0.00% utserver 1037 guest 1 44 0 3496K 1768K RUN 0:00 0.00% top 983 root 1 44 0 5412K 2712K select 0:00 0.00% telnetd 971 root 1 0 0 201M 7224K linuxf 0:00 0.00% utserver 880 root 1 8 0 4396K 2412K wait 0:00 0.00% bash Now I have working torrent, downoad in progress. There are quirks, I describe it later. Good work!
  7. OK, done. Some suspected parts, rest is/seems right: [03:59:49] UDP setsockopt(SO_RCVBUF, 2097152) failed: 105 [03:59:49] UDP setsockopt(SO_SNDBUF, 2097152) failed: 105 [03:59:49] UDP setsockopt(SO_RCVBUF, 2097152) failed: 105 [03:59:49] UDP setsockopt(SO_SNDBUF, 2097152) failed: 105 [04:00:03] Incoming connection from 90.156.42.82:64775 [04:00:03] 90.156.42.82:64775: Disconnect: No such torrent: 18568495FD35C09E33024BF5340A3B52971FCE6E [04:00:07] Incoming connection from 82.231.42.196:55974 [04:00:07] 82.231.42.196:55974: Disconnect: No such torrent: EDB76839A8BA4200E2C9C6CF96AF556FB45C6B91 [04:00:18] Incoming connection from 83.1.112.96:1198 [04:00:18] 83.1.112.96:1198: Disconnect: Peer error: Connection reset by peer [04:00:36] Incoming connection from 89.74.112.48:31459 [04:00:36] 89.74.112.48:31459: Disconnect: No such torrent: 18568495FD35C09E33024BF5340A3B52971FCE6E 04:01:16] 188.134.32.84:53435: Disconnect: Can't sync DH3 [04:02:13] Incoming connection from 78.8.71.140:48348 [04:02:13] 78.8.71.140:48348 [uTP]: Disconnect: No such torrent: 18568495FD35C09E33024BF5340A3B52971FCE6E [04:02:13] Incoming connection from 78.8.71.140:51537 [04:02:13] 78.8.71.140:51537: Disconnect: No such torrent: 18568495FD35C09E33024BF5340A3B52971FCE6E [04:02:14] Incoming connection from 70.131.117.118:6112 [04:02:14] 70.131.117.118:6112 [uTP]: Disconnect: No such torrent: 18568495FD35C09E33024BF5340A3B52971FCE6E [04:02:14] Incoming connection from 70.131.117.118:63896 [04:02:14] 70.131.117.118:63896: Disconnect: No such torrent: 18568495FD35C09E33024BF5340A3B52971FCE6E [04:03:04] ComputePeersToUnchoke() [04:03:04] max all_upload_slots = 0 [04:03:04] max downloading_upload_slots = 0 [04:03:04] max seeding_upload_slots = 0 [04:03:04] downloading_upload_slots = 0 [04:03:04] seeding_upload_slots = 0 [04:03:04] downloading_optimistic_slots = 0 [04:03:04] seeding_optimistic_slots = 0 [04:03:04] ComputePeersToUnchokeType(1) slots = 0 [04:03:04] distributing 0, local extra = 0 [04:03:04] ComputePeersToUnchokeType(0) slots = 0 [04:03:04] distributing 0, local extra = 0 [04:03:04] ComputePeersToUnchoke() complete [04:03:04] ComputeOptimisticUnchokes() [04:03:04] ComputeOptimisticUnchokesType(1) slots = 0 [04:03:04] new slot count: 0 (min(optimistic_slots = 0, arr = 0)) [04:03:04] ComputeOptimisticUnchokesType() complete 1 [04:03:04] ComputeOptimisticUnchokesType(0) slots = 0 [04:03:04] new slot count: 0 (min(optimistic_slots = 0, arr = 0)) [04:03:04] ComputeOptimisticUnchokesType() complete 1 I have some suspicions; there are well known old problem with utorrent on Wine+FreeBSD: Here is description with patch: http://forum.utorrent.com/viewtopic.php?id=45193 Explanation: "I think, this is a wine problem. Because getaddrinfo is called with ai_socktype=0 as hint, which makes the FreeBSD getaddrinfo fail with EAI_SERVICE, as seen in debugging output. But this is valid on windows, so wine has to be extended on FreeBSD in order to prevent getaddrinfo calls with ai_socktype=0." What You think about this?
  8. Installation on FreeBsd7.1/32 Success: it working, web interface working. It gets torrent from autoload directory and opens it. But, this is all. I have "Error ??", without any explanation. Can I ask about more verbosity in logs? Please... BTW: .in utserver.conf, strings must be WITHOUT quotes ut_webui_dir: "/usr/local/utserver: <------ BAD ut_webui_dir: /usr/local/utserver <------ GOOD