Jump to content

Lazy Mode / Settings


Recommended Posts

The lazy mode still isn't working for me.

My log says I'm doing this:

Incoming Connection from .....

ip address.... client......: handshake completed

ip address.... client......: got choke

ip address.... client......: disconnect : peer eof

And then it repeats this process for the other clients connecting.

Is there a settings file from my previous version that should've been deleted? Or is it still not lazy enough?

I can go into Superseed mode and connections will start being allowed, but only uploading a few kbs every couple minutes or so. Uncheck that, and the peers go to zero and the above mentioned log occurs.

What's very odd is, I can then start my Azureus via batch file, begin seeding the same torrent file while still running utorrent, and after several minutes (and after Azureus begins uploading), it (utorrent) will begin uploading correctly.

Please help.

Link to comment
Share on other sites

Yes- lazy bitfield in enabled.

Perhaps I spoke too soon. I fell asleep and let it run all night. Seems to have seeded fine throughout the night, so maybe it just took some extra time. I'll do some more testing and report back. Thanks for the response Ludde.

Link to comment
Share on other sites

This feature still isn't working properly for me.

It goes through this process:

incoming connection from .......

ip / client / send have

repeat several times

ip / client / handshake complete

ip / client / disconnect: peer eof

It repeats this process for all leeches trying to connect to me, and occasionally you'll see "got choke" appear. Every now and then it'll mention

aggrevated data" too.

I can let my torrent seed for hours and this is the result. I should mention the sending haves doesn't = uploading.

I can change properties to "superseed" and it's go from 0(6) peers to 5(6) peers.

Then it'll do the:

ip / client / got request ......

ip / client / sending piece.....

got uninterested

send choke

and sometimes it'll send unchoke.

This allows me to upload, but at superseed (ie. superslow) speeds. If I uncheck the superseed option, it goes back to 0(6) peers.

After a day or so, and not in superseed mode, it eventually begins to seed normally, to the same peers that have been connected for hours. That part baffles me.

Any ideas Ludde?


Link to comment
Share on other sites

  • 3 weeks later...

I've searched everywhere, and I don't really have a good idea of what the lazy_bitfield setting does. Does it just not tell the tracker that your download is complete, so that seeding isn't throttled by a provider? I read that's what it does, somewhere. But then other people say it speeds up your downloads as well. Does it just make your traffic look a little more "normal" and less "bittorrent-y" or something? *totally confused*



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...