Jump to content

great running torrents become internet molasses


Recommended Posts

I'm not the first to report a problem like this, but as none of the other posts have resolved it (to where it works for me), I wanted to add my specs to the soup of things and see what can be made from them.

I'm running the most recent, non-beta'd version of uTorrent at the moment. To ensure I was starting out healthy, I restarted my computer (specs available if needed), my router (Netgear WGT624 v3), and my modem (unbranded cable modem provided by Charter). I then followed the steps prescribed at http://www.utorrent.com/setup_guide.php to a tee. I tested my upload speed twice with testmy.net and averaged 473 Kbps upload speed. In uTorrent my settings are:

Upload limit: 47kB/s

Connections (per-torrent): 80

Max active torrents: 3

Upload Slots: 4

Connections (global): 230

Max active downloads: 1

I know I have successfully forwarded my port (41511) because the test from within uTorrent works just fine. I am not randomizing my port because I didn't want to add one more variable to why my setup doesn't work.

After performing all of the standard steps at http://www.utorrent.com/setup_guide.php (1-5), I ran my first of several torrents. It ramped all the way up to 350kB/s for the duration of the torrent download (maybe 10-15 minutes). It immediately began my next torrent in line (with an equitable number of seeds and peers) and began ramping up and connecting to upwards of 40 seeds when the speeds stopped increasing around 60kB/s and began steadily dropping (despite # of seeds connected). Within about 3-5 minutes I had dropped all the way to 0kB/s and was only uploading around .1kB/s.

This death of connection didn't only occur on uTorrent though, once exiting the program the internetless of it all persisted. Just browsing into here to post this took /forever/. I cannot test the other computer on my router at the moment to see what her connectivity looks like. I imagine that performing a clean restart of all three pertinent components would rectify the situation; but doing that every 20-25 minutes (or so) would be ... well, silly.



Link to comment
Share on other sites

I changed the Speed Guide to xx/384k as you suggested; among other changes it made to my settings, it also changed it to download two torrents simultaneously. FYI.

As for performance, torrent 1 originally found 300 seeds, and the mysteriously turned red and dropped to only 1 seed and tried to connect to it: 0.0kB/s. It then managed to connect to 2/2 seeds, and successfully connected to them averaging about .3kB/s. This torrent slowly began inching up in speeds, but only to about 5.7kB/s after several minutes ... and still only 2/2 seeds, yet connected to 1/579 peers. This torrent continued to fluctuate between 1/2 and 2/5 seeds, and speeds of 0-20kB/s. I still don't understand why it originally had over 300 seeds and then lost them.

Torrent 2 kept the 197 seeds it originally found and connected to three of them, managing a speed of about .1kB/s. It eventually climbed its speed to a space fluctuating between 0-6kB/s, and connected to between only 1-5/197 seeds.

I decided to drop to only downloading one torrent at a time after this, and started the OpenOffice torrent. With the OO torrent the only one running, after several minutes it still found no seeds, and had not managed to connect to any of the 210 peers it found. µTorrent eventually quit on this torrent and went on to the next one, which is the original torrent in this post; after which it still only connected to 3/10 seeds and 1/621 peers with no idea where the original 300+ seeds went. For both of these torrents, µTorrent gave them a green light only for a few seconds before the red one showed up and didn't go away.

As I finish writing this, I still have internet capabilities everywhere else on my computer and µTorrent finally found 2/2 seeds for the OpenOffice torrent and has begun downloading it at between .5 and 3.3kB/s. Granted it hasn't crashed my internetability, but it is also effectively impotent, especially when compared to the 350kB/s I managed for the one torrent last night. Am I, for some reason, condemned to either restarting everything every half-hour to find seeds and manage a respectable speed or to just download torrents very slowly and intermittently?

Link to comment
Share on other sites

Over the last few days, I've tried all the suggestions under the "SLOW/INTERRUPTED INTERNET CONNECTION/OFFLINE TRACKERS when running µTorrent" section, and none of them solved my problem.

I can say for certain that this seems to be a problem with my computer. I can restart my computer after losing all internet connectivity and then run µTorrent without any problems (in fact, with exceptional speeds, 120kB/s-ish at times) for upwards of ~15 minuted before they slow to a crawl and I effectively lose all connectivity again until I restart my computer again.

Anybody have any thoughts? Any help is greatly appreciated!


Link to comment
Share on other sites

Disable UDP packet-forwarding on your router (if you have one).

Disable UPnP and DHT in µTorrent.

...and reduce global and per-torrent connection max to under 100 total and 30 each.

As well as set half open connections limit in µTorrent to only 4.

...and at least see if it lasts 30 minutes instead of 15 or less.

What other software is on your computer.

A single packet may be 1500 bytes in size, but many routers, modems, and network cards (due to their programming and buffers) cannot handle more than maybe 10000 per second. So for many of them to reach max speed, the packets HAVE to be near max size.

But for UDP packets (and more exotic types!) the number may be 100 or less!

A 10 megabit/sec internet connection at best could handle about 740 max-sized packets per second.

An upload line of 384k can do about 30 max-sized packets per second. That's not 'fast' at all.

A Gigabit ethernet LAN connection often uses packets of 4000 bytes size or larger, so it gets more speed that way rather than just lots more packets per second. Often, most Gigabit ethernet cards in computers won't let them copy files across their network at faster than 20-25 MB/sec (about 180-250 megabits/sec) even if copying from a ramdrive to a ramdrive because of some other bottlenecks in the computer or network card!

(I was very disappointed when I looked to upgrade my old 100 megabit/sec LAN network to Gig-E when I read about this, as I was at best likely to only about triple my speeds instead of getting 10 times the speed.)

Half open connections are when an ip-to-ip connection is attempted by 1 end, but the other end hasn't responded yet. Sort of like making a phonecall but the receiving side hasn't answered the phone yet. You might be limited to making 10 new calls at once (half open limit set to 10) but be connected to a 'conferance call' with 100 other people/phones at once (100 global connections).

The global connections are for existing connections, not the rate to make new ones, although once µTorret nears max global connections it should slow down its new connect rate.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...