Jump to content

µtorrent bans its own ip address...


Recommended Posts

Hi all and thanks again and again for all the good work put into building this state of the art software that is µtorrent.

On some torrents (not all, most work fine), after some time downloading at normal speed my dl drops to about 0.5kbps for no reason (I am connected to seeds no problem, I just don't get anything from them) and when I reset bans on the torrent my ip address is part of the banned list, with the forwarded port attached (-> 'unbanned xxx.xxx.xxx.xxx:xxxxx').

I haven't noticed any difference between unbanning and not unbanning myself, actually everytime I click on 'reset bans' my ip address gets unbanned again so I guess that µtorrent bans me again everytime.

Though it is very strange I guess it is more the torrent that has a problem than µtorrent itself.

Does anyone know a way around that ?

Thanks in advance.


Link to comment
Share on other sites

  • 3 months later...

I'm having the same issue. When I reset bans, my IP address shows in the log then the downloads resume. Resetting the ban allows me to connect for a brief moment then the downloads stop again.

Is this feature to reset IPs that I have banned or IPs that have banned me?

I've read the troubleshooting pages with regard to the Linksys router issues but there wasn't a listing for v8.00.0 so I've not updated the firmware with HyperWRT Thibor or DD-WRT. Is my version supported? If so, would this correct my issue?

Any suggestions/ideas would be appreciated.



Linksys WRT54G v8.00.0

μTorrent v1.6.1 (build 490)



Link to comment
Share on other sites

  • 2 months later...

I am having the same problem as cloudhurler and repost. I thank you for the replies from Switeck. I understand about the ipfilter.dat file and not being banned.

The problem I am having is I start my utorrent and start a torrent file. It goes through its process and starts to download. (It does not matter on the torrent). For example, After I connect to the swarm, I will start downloading around 200 kb/s. WITHIN 1 to 4 minutes, I am still connected to the same amount of seeders/ leechers, and my download speed is from .5 k/b/s to 4 kb/s. I do a reset bans and My ip address (192.XXX.X.X:PORT) is unbanned and my download speed will resume to 200kb/s. I have to do this all the way through the torrent.

This is not a configuration problem but a software problem I believe. I tried turning off the peer discovery and added my address to the ipfilter.dat and still get the same results. Not only on a tweaked utorrent install but also on a fresh install on a new system.

This all started when I tried the 1.7 build and also on the last 1.6 build.

I also tried connecting straight to my dsl router and also went over to a friends house and connected with his cable modem and the same results.

Any help would be much appreciative.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...