Jump to content

utorrent connects fine, sends spurts of data, then stops?


Recommended Posts

Hi all,

I tried searching in the FAQ but I cant find anything that applies directly to my issue. Ive been running utorrent 1.6.1 (and prior) for a very long time without any problems.

All of the sudden my uploads are uploading fine, going to max speed, then all the sudden they disconnect. (this started happening around April 21, but I thought it was simply the tracker I was using)

Users who are connected to me have said that if they stop and restart the torrent it will run fine, then disconnect again.

I have a WRT54G V3 router, I had Hyperwrt tofu firmware on it until today i decided to try DDWRT because of the connection issues (i figured just upgrading the firmware would help) but obviously that isn't the problem.

Ive rebooted/restarted my router

Checked my cables

I have protocol encrpytion enabled

I have used the speed guide to fix my settings

As far as I know my cable isn't blocking traffic (comcast)

I've tried 3 different firmwares for the router

I don't have a disk overload message (I keep my speeds at 30k/s in the daytime, 70k/s which is slighly below my max, at night)

I have no problems downloading

I have my ports forwarded (Ive even tried other ports for kicks.. and they aren't in the 6881 range)

DHT is disabled

Utorrent says my connection is fine (green check mark)

I also tried utorrent 1.7 AND azureus with the same results.

The uploads will again run fine, then slowly go down to 0.00kbs then maybe 30 seconds-1 minute later start up again. This has happened on several trackers with several different files. I have no idea whats going on.

The only thing I can really think of is i updated McAfee, but I have their firewall off and most of the settings except the virus scanner disabled. I have windows firewall off and am using Sygate Firewall Pro, ports forwaded (again never had an issue with this). I also turned McAfee off, as well as my firewall and am still having this problem.

Here is a sample of the log as I was seeding one torrent with one leecher (the same thing happens with any other person who connects to me)

[12:02:26] Incoming connection from xx.xx.45.114

[12:02:27] xx.xx.45.114 : Disconnect: No such torrent: B852A2ACC1925F90137DF6F574A61436720C51FB

[12:02:27] xx.xx.242.214 : [Transmission/0072]: Got Request: 534:0->16384

[12:02:28] xx.xx.242.214 : [Transmission/0072]: Sending Piece 129:0->16384

[12:02:28] xx.xx.242.214 : [Transmission/0072]: Sending Piece 422:49152->16384

[12:02:29] xx.xx.242.214 : [Transmission/0072]: Got Request: 534:16384->16384

[12:02:31] xx.xx.242.214 : [Transmission/0072]: Got Request: 534:32768->16384

[12:02:32] xx.xx.242.214 : [Transmission/0072]: Sending Piece 129:16384->16384

[12:02:33] xx.xx.242.214 : [Transmission/0072]: Got Request: 534:49152->16384

[12:02:34] xx.xx.242.214 : [Transmission/0072]: Sending Piece 129:32768->16384

[12:02:34] xx.xx.242.214 : [Transmission/0072]: Sending Piece 129:49152->16384

[12:02:34] xx.xx.242.214 : [Transmission/0072]: Got Request: 261:0->16384

[12:02:34] xx.xx.242.214 : [Transmission/0072]: Sending Piece 534:0->16384

[12:02:34] xx.xx.242.214 : [Transmission/0072]: Sending Piece 534:16384->16384

[12:02:34] xx.xx.242.214 : [Transmission/0072]: Got Request: 261:16384->16384

[12:02:35] xx.xx.242.214 : [Transmission/0072]: Got Request: 261:32768->16384

[12:02:35] xx.xx.242.214 : [Transmission/0072]: Sending Piece 534:32768->16384

[12:02:35] xx.xx.242.214 : [Transmission/0072]: Got Request: 261:49152->16384

[12:02:35] xx.xx.242.214 : [Transmission/0072]: Sending Piece 534:49152->16384

[12:02:35] xx.xx.242.214 : [Transmission/0072]: Sending Piece 261:0->16384

[12:02:36] xx.xx.242.214 : [Transmission/0072]: Sending Piece 261:16384->16384

[12:02:37] xx.xx.242.214 : [Transmission/0072]: Got Request: 338:0->16384

[12:02:37] xx.xx.242.214 : [Transmission/0072]: Got Request: 338:16384->16384

[12:02:37] xx.xx.242.214 : [Transmission/0072]: Got Request: 338:32768->16384

[12:02:37] xx.xx.242.214 : [Transmission/0072]: Sending Piece 261:32768->16384

[12:02:37] xx.xx.242.214 : [Transmission/0072]: Sending Piece 261:49152->16384

[12:02:37] xx.xx.242.214 : [Transmission/0072]: Sending Piece 338:0->16384

[12:02:38] xx.xx.242.214 : [Transmission/0072]: Got Request: 338:49152->16384

[12:02:39] xx.xx.242.214 : [Transmission/0072]: Got Request: 92:0->16384

[12:02:40] xx.xx.242.214 : [Transmission/0072]: Sending Piece 338:16384->16384

[12:02:40] xx.xx.242.214 : [Transmission/0072]: Sending Piece 338:32768->16384

[12:02:40] xx.xx.242.214 : [Transmission/0072]: Sending Piece 338:49152->16384

[12:02:40] xx.xx.242.214 : [Transmission/0072]: Got Request: 92:16384->16384

[12:02:41] xx.xx.242.214 : [Transmission/0072]: Got Request: 92:32768->16384

[12:02:41] xx.xx.242.214 : [Transmission/0072]: Got Request: 92:49152->16384

[12:02:42] xx.xx.242.214 : [Transmission/0072]: Sending Piece 92:0->16384

[12:02:43] xx.xx.242.214 : [Transmission/0072]: Got Request: 588:0->16384

[12:02:43] xx.xx.242.214 : [Transmission/0072]: Got Request: 588:16384->16384

[12:02:43] xx.xx.242.214 : [Transmission/0072]: Sending Piece 92:16384->16384

[12:02:44] xx.xx.242.214 : [Transmission/0072]: Sending Piece 92:32768->16384

[12:02:44] xx.xx.242.214 : [Transmission/0072]: Sending Piece 92:49152->16384

[12:02:44] xx.xx.242.214 : [Transmission/0072]: Sending Piece 588:0->16384

[12:02:44] xx.xx.242.214 : [Transmission/0072]: Got Request: 588:32768->16384

[12:02:44] xx.xx.242.214 : [Transmission/0072]: Got Request: 588:49152->16384

[12:02:45] xx.xx.242.214 : [Transmission/0072]: Got Request: 232:0->16384

[12:02:46] xx.xx.242.214 : [Transmission/0072]: Disconnect: Connection closed

Then it will simply start up.. and keep disconnecting. Can anyone help me out? Again I'm completely baffled as I've had no previous issues with utorrent (especially like this!)

Link to comment
Share on other sites

To eliminate McAfee as a problem, try uninstalling it for awhile.

Also try uninstalling Sygate Firewall Pro as well.

With your router only forwarding the 1 port, you're pretty safe even without a software firewall...but if that makes you uncomfortable, reenable Win XP's firewall and allow µTorrent.

If the problems seem to disappear with the temporary removal of McAfee or Sygate...well, you can try reinstalling them and configuring them in detail to see what in them causes the problem -- but chances are it's not a configurable setting causing the problem. :(

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...