Jump to content

Struggling with ports


Recommended Posts

Okay, I will get to the point fast. Ive never in my life configured ports, havent ever needed to. I now have a router (Netgear DG834GT) and its been up and running for about a day, and now I wish to download using uTorrent. And, they seem to be dead.

Ive got some torrents running very well, they all have above 1000 seeds so thats probrably why. And then I have 2 other torrents, which seem to be giving me hell, they have about 60seeds yet are not doing anything at all! Its frustrating me, because I have not configured any ports, yet some torrents work and then these other 2 are dead.

I have Wiindows XP SP2, a Netgear DG834GT router, Zone Alarm Pro Firewall and Norton System Works 2005.

A little help would sure do the trick right now, a basic understanding of ports is what I need and an answer to my problem (even though I just think that these 2 other torrents, even though have 60seeds, are dead, it still confuses me though)

Oh yes, it might also help for me to say I followed the FAQ which lead me to portfowarding.com and another time. PortFowarding, I followed the guide religiously and it didnt work, in fact, I had 2 msn messenger's open at the time, and they were going haywire, signing in and out. Then the other site, I tried on both the port im said to be on, and the port that was already there and both times it said FAIL! which was wierd....

Anywho, thanks for reading, and please help! Thanks in advance


EDIT: Just looked back at them downloading, the few I said were downloading, are still downloading, but Ive noticed theres a NAT ERROR written at the bottom. Does this make a difference?

EDIT 2: SHIT! I put this in the wrong forum!!! I swear I clicked on troubleshooting!!! Can an Admin please move my topic? Sorry for the inconvienience

Link to comment
Share on other sites

The NAT error indicates that either your router or your firewall (or both) is blocking µtorrent.

as to a basic understanding of ports - to put things very simply: the same way that an IP address tells a packet which computer is its destination, the port conveys information as to which application within the computer is the destination.

if the problem is in ZA pro (which I use as well), the simplest solution is to

1. exit µtorrent

2. go to

Program control --> programs

right click on utorrent

and select remove.

3. open µtorrent again, and when ZA asks if it should permit µtorrent to access the internet zone or to act as a server, say "Yes", and check the "remeber this" check box.

if the problem is with the router, I hope someone else will be able to help.

good luck,


Link to comment
Share on other sites

I just thought of a way that you can check if ZA is the problem:

1. double click the ZA icon in the tray

2. at the upper - right section of the ZA window there is a drawing of an open lock, next to which are four squares.

3. one of these square should contain a drawing of a hand holding the µtorrent icon. (it could be blinking)

4. put your mouse cursor above it. if it says "utorrent.exe listening to port ..." you're ok. if it say that utorrent.exe is blocked from listening to this port, then ZA is causing your NAT error.

Link to comment
Share on other sites

to troubleshooting we go

NAT Error means you can't receive any incoming connections, which WILL hurt performance.

I can't help you with your router but, did you make sure you turned off the Windows Firewall / ICS service?

If you use an alternate firewall while on Windows XP SP1 or SP2, make sure you turn off the Internet Connection Firewall (SP1) or the Windows Firewall (SP2).

You may still have to disable the Internet Connection Firewall (ICF) or Windows Firewall / Internet Connection Sharing (ICS) service to prevent a conflict between it and your third party firewall. Control Panel -> Administrative Tools -> Services, scroll to appropriate service (ICF or Windows Firewall/ICS), right click and select Properties, select Disabled in the drop down menu and hit OK.

Link to comment
Share on other sites

Okay, as mentioned in hofshi's second post about ZA Pro, I rebooted my computer (because the picture wasn't there, there must've been to many apps connecting to the internet and utorrent got left out) It says "utorrent.exe Listening to port(s): TCP:32459" so I presume ZA is not my problem.

Everything was swimingly fine with ZA and my SpeedTouch 330 (not a router though, just an ADSL connector) so I presumed it was not ZA.

Anyway, I went on utorrent and there was no NAT Error at the bottom (the download is still going slow) went out of the room, returned about 10minutes later and the NAT Error is back on my screen again. Meanwhile, I havent seen the torrent go above 8kb/s and was going at a quite steady speed of about 5kb/s (just as I typed it it plumated to 0.2kb/s, lol)

In accordance to what Firon said, I tried doing that earlier (admitidly not for a very long time, but it seemed to do nothing either way, I will try that in just a tick.

Oh, and I tried exiting utorrent and then removing it from ZA, then starting up again, and that appears not to have done anything in the slightest.

Anymore suggestions?

Link to comment
Share on other sites

Anybody got any suggestions to this one....

I have both Emule and uTorrent running, and i have successfully got rid of the NAT Error (I think, I havent seen it) that was there, and got rid of the LowID I had on Emule. But, im still getting VERY low download rates, well, low compared to the rates that I should be getting/Usually get.

On most of the my files in Emule, im getting above 5kb/s each. But in uTorrent im getting bellow 2kb/s on both downloading, even though ive switched to different torrent files (As I am now downloading the other 2 I wanted on Emule)

Anybody know anything that could cause them to go so low? Before I installed the router, I was very happy with uTorrent, because it made my downloads faster, more efficient and used less system resources. Now it seems that its just not working at all. Help please....

Thanks in advance

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...