Jump to content

Upload not using full bandwidth


Recommended Posts

When I seed 2 torrents (let's say X and Y) the total upload speed is never goes over 80kb/sec. But my max upload speed is 96kb/sec. So I tried this,

On the same machine started vmware and in vmware installed another win-xp. Then I started torrent X from the main win-xp and torrent Y from the virtual win-xp. When I look at the combined upload speed is comes close to 94kb/sec.

When I only let torrent X run the upload speed for this torrent goes up, but still not higher then about 80kb/sec.

So, when seeding only 1 torrent, the upload speed is about 83% of max bandwidth. When seeding 2 torrents from 2 machines the upload speed goes up to about 97.9% of max bandwidth (even if one machine is virtual).

In all running uTorrent's I have not limited the upload/download speed.

Its hardly unlikely that the amount of leechers is to blaim. In all instances there where over 100 leechers reported by the tracker and between 10 to 28 (per torrent) connected with me. Torrent X and Y were both very big (over 10GB) so seeding took time enough to do this test.

Can somebody explain this speed difference?

Link to comment
Share on other sites

Currently running 1 uTorrent and have the upload speed limited to 90kb/sec. It's running like this for 20 minutes and it seems the speed drops to an average of 70kb/sec.

I thought uTorrent would use 100% bandwidth if possible and detect it when another program (like Firefox) tries to use the internet connection, so it can drop its speed.

Could it be that uTorrent is programmed to never go faster than about 80% of max upload speed? And only when running 2 clients go over 80%?

Link to comment
Share on other sites

Here they come:

Connection type: (Current settings)

Upload Limit: 0kB/s

Upload Slots: 25

Connections: 125

Connections (global): 800

Max active torrents: 15

Current Port: 42xxx (I have the green tag and the port is open)

Enable Encryption: on

It has been running with an upload limit of 90kb/sec for about 8 hours and the moment I removed this setting and filled in 0kb/sec (unlimited) again, the upload speed went up from 69kb/sec to 78kb/sec.

Currently there are only 2 torrents seeding. The status of all others is Finished.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...