Jump to content

pre-allocate disk space bug


Recommended Posts

I try to download a torrent with 10 Gb of data in 10 files.

I only have 5GB free on my harddrive.

I have enabled in options "pre-allocate disk space" to help with hd fragmentation.

New torrents start in stopped mode. (Works fine and nothing is pre-allocated yet)

I choose the stopped torrent and tell utorrent to skip the last 5 files ("don't download") because i only have 5gb free.

i click the start download button and viola - Error: not enough diskspace ..

and looking at the files pre-allocated, utorrent tried to allocate all files (even those marked to be skipped) - thus. i can't donload anything.


sorry - found this now http://forum.utorrent.com/viewtopic.php?id=3579

reading the faq only makes things more complicated..

what setup should i use to make the example above work best?

i read that pre-allocat diskspace isn't necesary because files are allready preallocated.. what is the reason for that option then and what does it actually do when turned on ? on a windows xp with ntfs on the disk what is recommended of diskio.use_partfile, sparse_files and compact allocation?

Link to comment
Share on other sites

Use the beta, and search before posting next time.

Pre-allocate (in µt) only does one thing: allocate all the files when you start the torrent to make sure you have enough disk space.

With it off, the files still get allocated fully, but it happens whenever µt has to write data for a file, instead of all of them at once. You get the same exact effect though: reduced fragmentation. Turning on pre-allocate doesn't improve this at all.

Link to comment
Share on other sites

My suggestion would be: files that are skipped, should NOT be allocated. As you do not (want to) download them. What is the sense anyways of an allocated file that will not get downloaded?

Sometimes people offer 20Gb torrents, you want to download them partly or piece by piece, because you only have a 10Gb harddisk... but with uTorrent this is currently impossible.

It looks to me like a small change in the code to skip allocation for skipped files.

Anyways... happy new year to all you u-guys!

Link to comment
Share on other sites

I understand that it is a bug and maybe not one easy to fix. So all I can do is wait and hope that it gets fixed soon.

But in the meantime, I have to say, I absolutely HATE this bug. If I select files not be downloaded I do not want utorrent shoving them on my throat and allocating space on my hard drive for it. I'm not a bot or an idiot and I don't want utorrent being a do-gooder and allocating space, just in case I don't have enough for the torrent.

It is my friggin problem if I don't have space for it and if I don't check that.

What I want for my torrent client is to write to disk as it downloads, incremental. Not fill up my disk every time I start a bleeding torrent.

And before you say anything, I'm not using betas. I have no confidence to try a beta of a client of which no-betas version can do such completely idiotic things.

So, till this is sorted I'll go back to my old client.

Link to comment
Share on other sites

It only happens if you use pre-allocate, and you're apparently not doing that. If you're not using pre-allocate, it only allocates files when it has to write data for them.

What you want is to use diskio.sparse_files, which DOES work properly in older versions, and was added precisely for that purpose (so files don't get allocated in full). This will makes files get written in a way that saves space. The size looks the same, but if you look at the properties, you'll see that Size on disk is much, much smaller.

Link to comment
Share on other sites

The problem is, that pre-allocate is a good feature if you're low on harddisk... it's stupid to download 4.2Gb of a DVD to find out that the last few small files will not fit and the whole download is a waste... pre-allocate will tell you upfront if you have disk or not.... and will also prevent you of eating diskspace during the download (which sometimes takes several days)....

But again... still.... I do not like files being allocated that are SKIPpers... I consider this as a bug, that is pretty annoying. I would be very happy if this get fixed! It would mean that uT supports both nice feature correct.

Link to comment
Share on other sites

If you're not using pre-allocate, it only allocates files when it has to write data for them.

no, i'm not using it and never have (I disabled it from the first install of utorrent). but it still allocated the space, the minute I started the torrent.

I have changed diskio.sparse to true and it has indeed worked like you said: apparently size is the same, but really, size on disk is only what has been downloaded.

The trackers I'm on don't allow the use of betas of any clients so I'll wait patiently for the next stable version.

Thank you

Link to comment
Share on other sites

diskio.sparse_files is in the stable version, and has been for a long time

I didn't express myself correctly: now that I found out about diskio_sparse I am using utorrent again, AND, at the same time, I am waiting patiently for the new version so that I can enjoy the other nice features users of the current beta rave about.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...