Jump to content

Can't connect to peers/seed


Recommended Posts

Hey guys, I need abit of help, utorrent has been working fine for years and suddenly I can't connect to peers and seeds anymore (if I wait awhile I may get 1 or 2 seed/peers). I didn't install any new program or application. I also tried turning off Windows firewall but still no luck.

DHT is usually stuck on waiting to announce or announcing

I tried the torrent from openoffice but it won't even connect (red dot)

I also tried calling my ISP and they said that they don't block DHT/ torrents

port forwarding test seems to work fine most of the time but sometimes I get an error msg that says the port is blocked.

I'm using Motorola surfboard cable modem for connection,

Any kind of help is appreciated, thanks :D

Link to comment
Share on other sites

"Motorola SurfBoards are known to cause portforwarding issues"

Those are cablemodems...you mentioned having one.

What router are you using?

What settings in uTorrent? (those shown by Speed Guide CTRL+G and any advanced settings changes)

What's the measured (via online speed tests) speed of your connection both down and UP?

Link to comment
Share on other sites

I don't use a router. My computer connects directly to the modem. And I use this settings: 2 upload slots, 100 connection/torrent, 200 global, 2 active torrents, 1 max active dowloads. Speed tests around 784kilobit DL and 256 UL. I can't figure out what's wrong. The bottom bar of utorrent says no incoming connection (problem with network config), but I turned off Windows firewall already.

Link to comment
Share on other sites

  • 1 year later...

I had the same problem: more than 20 seeds and still no connection to any of them, stuck at 99,2%, ratio less than 1. Despite my connection indicator was green (sign for "everything running ok with your connection"), i was days stuck at the end of the torrent.

Bad/fake torrent? NOT!

I was googling about it, so i found this thread. I'll name some of the problems one might have:

- Windows firewall?

In uTorrent Preferences, under Connection you have a button for "Add Windows Firewall Exception". That makes uTorrent look safe for windows firewall and works fine. But you can allways check it manualy in windows, it wasn't my problem.

- Port Forwarding?

I didn't do it, though i'm under a router, uTorrent has an option (at the same place) for "Enable UPnP port mapping". This is like an automatic port forwarding and it worked for me too, without having to tinker with the router. It was not the problem.

- Too many torrent jobs? (even in stopped status!). That was once a problem for me, clearing your torrent list - even the inactive ones! - helps improve performance a lot. But that wasn't the problem either!

Then i checked one thing i had never tinkered with:

the "Randomize port each start" option.

Then closed and started uTorrent again. THAT WORKED IMMEDIATELY! I got my last bits of torrent in minutes. 8)

I don't know why, but maybe the UPnP wasn't working with the current selected port, so by changing the port it worked. And when i'm stuck again, maybe i'll just have to restart uTorrent and let it try another port. =)

Hope this helps somebody.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...