Jump to content

Another speed issue.....sorry!


Recommended Posts

Right folks, you know whats coming but thanks in anticipation.

I used to use utorrent fine when on BT (British Telecom....I'm in the UK) but having since moved to Sky I am having no-end of problems getting some speed up. I've spent the last three hours going through all the suggestions but have now done that many alterations in the set up that I dont know where I began!

I've managed to download (or am I uploading?) some 50mb-ish size files but they did take an age. I'm attempting to load a 1.23Gb file but geological timescales pass quicker. Nearly 24 hours in and the average dl speed is 2.8kbs and the upload is 3.8kbs. Typically I've had 2(4) seeds and 4(10) peers. I've tried 'other' torrents to see if this one was 'sticking' but they're all at it now.

Hopefully by answering the standard questions you may be able to get the ball rolling.

My network status light is green (it does go to amber but very rarely).

* The state/value of all of the options you were recommended to change up above.

My max upload rate is 22kbs and my max dl rate is 15kbs.

My global max number of conection is 130 and my max number of connected peers per torrent is 30.Number of upload slots per torrent is 3. My connection type is currently at 256 but I have tried 64, 128 and 512 with no luck.

I'm using a random port.

Port 52008 is open and accepting connections. This is good?

My download speed is 624 kbs and my upload speed is 144kbs. Note that I used a site in the USA and I'm in the UK though. I tested this earlier and it was reading 242 and 231 respectively though?

* What you have net.max_halfopen set to (Preferences > Advanced in µTorrent). This is set to 8.

* Operating system installed (Windows XP, 2000, ME, 98, 95, NT? Something else?). I'm on XP SP2.

* Security software installed (firewall, antivirus, antispyware, antiadware). I have McAfee though I have disabled it. Windows is also disabled.

* Exact router model(s), and exact modem model.

I ran Belarc advisor but nothing shouted 'router' at me, could it be this? Belkin 54g Wireless USB Network Adapter

Realtek RTL8139/810x Family Fast Ethernet NIC. Probably not, may need some help here.

* ISP (Internet Service Provider) being used. I'm on Sky Broadband. My current speed is 54Mbps though its usually in the 30's.

I did try the slackware torrent as a test but this has done nothing thus far. In fact, everything seems to have ground to a resounding halt.

I think thats it but if you do respond and dont get a reply straight away I'm not being rude but have to disappear now but will check again this time tomorrow all being well.

As I said TIA.


Link to comment
Share on other sites

2nd link in my signature...try the 224 or 256 kilobits/second upload settings.

Those seem closest to what you have.

Your "Belkin 54g Wireless USB Network Adapter" may not be able to handle lots of connections at once...so also disable: DHT, LPD, UPnP, NAT-PMP, and Resolve IPs (in Peers window, right-click on active torrent).

You may have to fully uninstall McAfee to fix your problem...or just to rule it out. :(

Link to comment
Share on other sites

Resolve IPs is found in the PEERS window at the bottom of uTorrent's window. You have to right-click in the PEERS window with an active torrent selected at top. This should pop-up a menu -- with Resolve IPs as well as a few other things on the menu.

In Preferences, BitTorrent:

Try setting Outgoing Encryption to ENABLED or Forced...and then test both with and without incoming legacy (unencrypted) connections.

You ISP may be screwing with your speeds by crippling or killing any BitTorrent connection it sees.

Was McAfee disabled or uninstalled?

Uninstalling is almost required for testing because even when disabled, McAfee leaves MANY active DLLs in memory which might cripple uTorrent.

I read somewhere else that Realtek network cards have driver issues, possibly helped by updating to latest drivers. Just a rumor, but something to follow up on...

Link to comment
Share on other sites

Thanks for that. To update disabling resolve IPs had an imprved effect (double figures!!) but I'll need to look at it over some time to see if its just a peak or more prolonged.

I dont trust myself to be able to reinstall mcafee if I uninstall it so will hae to give that one a miss for now.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...