Jump to content

Files randomly coming up as "Unavailable", yet they're still seeding

Deputy Cartman

Recommended Posts

Hello, everyone. I have been running into a random error over the past two to three days or so and seeing as I think uTorrent is God's gift to BT applications, I decided to do whatever I could to help get this error fixed instead of just living with it.

First of all, forgive me if this has been posted before. I closed the Windows pop-up error that uTorrent gave me and I can't remember exactly what it said. I looked for "File unavailable" and got one unrelated thread and I looked for "File not found" and found 47 pages of stuff, and sorry, but I do not have the time to read through all that.

Anyway, I am currently running uTorrent 1.4 under Windows XP Pro with SP2 and all security patches and the like. About two or three days ago, files that I am seeding would randomly pop up as "Unavailable", yet they were clearly there. I would right click on the file's entry in uTorrent, click Force Recheck, and uTorrent was reminded that it was indeed there. It seems to happen to random files at random times.

I will be glad to do whatever I can to help fix this bug. If it is indeed a bug, that is. If a coder needs debug information or driver information from my system, please just ask and I will get it for you.

Link to comment
Share on other sites

I was sitting here listening to some music before having to get back to work when it happened again. uTorrent was humming along, seeding some torrents, when it happened. The following images are hosted on my server.

The error message.

What uTorrent looked like immediately afterwards. The error message in its entirety reads "Error: The system cannot find the file specified."

After taking the pictures, I right clicked on the troublesome torrent, clicked "Force Re-Check", it verified the file's hash, and it went back to seeding, just like it was before. Very odd.

For what it's worth, I tried clicking Help > Debug info, but that did absolutely nothing for me. Oh, and I almost forgot the results of Help > Show statistics... right before I restarted the torrent.

Total uploaded: 4.16 GB

Total downloaded: 8.98 GB (Unrelated note: The torrent site I'm on has me at an overall ratio of 1.12, I swear!)

Total running time: 91:21:30

Number of files added: 43

Program started: 4 times

# incoming conns since start: 58

# outgoing conns since start: 1841

Size of disk queue: 3

# connections: 0

# half-open: 0

The only noteworthy change I noticed in it after restarting the torrent was that the disk queue went from 3 to 1.

Link to comment
Share on other sites

Torrents that are still being downloaded go in E:\Downloads\BitTorrent\Incomplete. Upon finishing, they are automatically moved to E:\Downloads\BitTorrent\Complete.

One time I ran into some funky errors when extracting a rar file's contents and the built-in folder hierarchy surpassed 255 characters when extracted to the folder I chose, but that's obviously not the case here.

Link to comment
Share on other sites

The RAR files I mentioned were obtained via DC++, if memory serves. Furthermore, the files I'm working on now are basically structured like this:

Season 1\01 - blah blah blah.avi

Here's the full file name for one of the files I'm seeding right now:

E:\Downloads\BitTorrent\Complete\Battlestar Galactica Season 1\Battlestar Galactica - Miniseries (Pilot 2003).avi

It's not a problem with the files because their names are too long, it seems to be a bug. That miniseries.avi file's location is 113 characters long, a far cry from the 255 character limit where Windows starts shitting itself. I'll move the downloads around later if I feel like it, but right now I don't. If it was truly an error because the directory/file length was too long, one would think it would be happening constantly. If memory serves, when I ran into that error last time where the file's location surpassed 255 characters, Windows was unable to load or find the file at all. Double-clicking on the file produced a "file not found" error. That's not the case here.

The last error happened roughly 17 hours ago and hasn't happened again since, so I think it's just a random bug.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...