Jump to content

consistent at wotk -- inconsistent at home


Recommended Posts

THE PROBLEM: Downloads speeds are inconsistent – and before you start talking about the swarm – I can open the same torrent on another network (at work) and have very consistent results. Here are some main points:

• Sometimes (maybe 25% of the time) I can get a full bandwidth DL

• I can open a torrent, get a full bandwidth DL, stop and restart the torrent and get < 10KB/s for the remainder of the DL (multiple restarts don't usually produce any additional change in DL speed)

• Sometimes I can't ever get > 10KB/s DL

• If I open these same torrents at work (within minutes of my attempt from home) I always get full bandwidth DL

THE SETUP: uTorrent 1.8.2, Vista 64, Linksys WRT310N, Charter Cable 5mb/512k…and I'll summarize that I've done all the things recommended in the guides none of which had any effect. If you want all the details…enjoy reading below…either way…got any good advice? Thanks!!!

• The state/value of all of the options you were recommended to change up above.

o Try testing a torrent from OpenOffice.org-----inconsistent like all others

o Try enabling Protocol Encryption-----done, no change

o Made sure peer.lazy_bitfield is enabled-----done, no change

o Test your connection with Glasnost-----can't get it to work on IE8 Java 6.13

o Try using Switeck's conservative settings-----done, no change

o Try lowering net.max_halfopen to 8 or lower-----done, no change

o Try disabling IP resolving-----done, no change

o Try disabling DHT----done, no change

o Try disabling UPnP and NAT-PMP-----done, no change

o Try disabling peer.resolve_country-----done, no change

o Try lowering maximum global number of connections to 200-----done, no change

o Try patching TCPIP.sys----vista64 I aint messing with this

o Connect your computer directly to the modem-----didn't try this yet

• Color of the network status light in µTorrent's status bar (at the bottom of the µTorrent main window)


• What the port checker from the Speed Guide writes

o Checking port 52525 on! Port 52525 is open and accepting connections.

• What the Speed Guide shows your settings to be (press Ctrl+G in µTorrent)

o Connection type = xx/512

o Upload limit = 47

o Connections = 90

o Active torrents= 3

o Slots = 4

o Global connections = 100

o Active downloads = 2

• What you have net.max_halfopen set to (Preferences > Advanced in µTorrent)

o Default was 8

o Currently using 4

• Operating system installed (Windows XP, 2000, ME, 98, 95, NT? Something else?)

o Vista64

• Security software installed (firewall, antivirus, antispyware, antiadware)

o none

• Exact router model(s), and exact modem model

o Linksys WRT310N

• ISP (Internet Service Provider) being used

o Charter

• Connection type (DSL, cable, dial-up), and the results obtained from the speed test

o Cable 5megabit/.49megabit (512k)

Link to comment
Share on other sites

Are you using wireless networking?

The computer I use for uTorrent is connected via CAT5e, but I do have a laptop using WiFi.

Did you try 3rd party firmware on the router?

Negative, but I do have the latest Linksys firmare on the device.

Any chance the router's overloaded?

Not really. I dont host any services.

There is no evidence of attack, malfunction or misconfiguration.

I only have two computers on this network.

Other than uTorrent, I only do some web browsing.

Link to comment
Share on other sites

I've read your router doesn't handle lots of connections at once very well unless it's using custom firmware. Many Linksys routers have that problem. :(

Try all this at once:

lower bt.connect_speed to only 1.

net.max_halfopen to 4.

Disable UPnP, NAT-PMP, DHT, LPD, Resolve IPs

Reduce global and per-torrent connection max to only 30.

Make sure your incoming port is both forwarded and NOT overloaded by incoming ips. If your router is getting "hit" by 100's of incoming ips a minute, its routing tables can fill up in well under an hour.

Try Protocol Encryption outgoing set to FORCED and then test without and later with incoming legacy (unencrypted) connections.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...