Jump to content

Peculiar uploading issues.


Recommended Posts

I've looked around the forums, but try as I might, I can't seem to find a problem like the one I'm having. Well, not entirely, at least...

Anyways. Bare with me here, its a bit odd, and I tend to be a bit rambly.

Basically, my issue is this. Occasionally, when I'm running a torrent, and have the upload speed higher than 1-2k, it slows my entire connection to a crawl. This doesn't always happen though, it was working fine earlier today with a max of about 6k (I've got rather low end dsl, so 6-8k is about the best I can manage before it begins to severely effect my connection)...then storms knocked out my connection for a few minutes, and when it came back up, well, I ran into the issue I stated above.

Sometimes though it'll simply decide to act up with no outside factors as far as I"ve been able to tell.

I've noticed this issue tends to be very random, with no apparent rhyme or reason as to the cause.

Got my hands on a program to measure my connection speeds (AnalogX NetStat Live), and discovered that for some reason, utorrent seems to be uploading more than it is set to. Right now I've got it set to 1k, but its uploading around 4-5k.

I've done a good amount of testing, and removed everything else from the equation, so I know for a fact its something in utorrent causing it....but try as I might, I cannot track down what. I found an ooold post (back in 2007) on another site stating something about a corrupt config, so I deleted everything utorrent related I could find, reinstalled, etc...but the problem persists.

I've checked all my settings several times over, rebooted router/modem/computer, made sure ports were forwarded properly, and followed various other speed tips I've found here, but to no avail. (I wasn't expecting much from the speed guides since it usually runs just fine, but I figured it was worth a go.)

As thus brings me here, in hopes maybe someone can help me?

Link to comment
Share on other sites

Actually I don't use encryption. And besides, when I reinstalled it defaulted to no anyways, and thats what I've done all my testing under.

Doesn't quite explain why it'd be so bloody random though. It'll probably keep up like this for a day or so (or longer), then just up and start working properly again for a few days before breaking, again...

I suppose in theory I could simply never raise the upload about 1k...but that's kind of a dick thing to do.

Link to comment
Share on other sites

Disable: UPnP, NAT-PMP, DHT (both kinds!), LPD, Resolve IPs (right-click in bottom Peers window of a torrent)

Reduce bt.connect_speed to 1-4 outgoing new connection attempts per second. (The default of 20 could be a bit much.)

And lastly reduce global and per torrent connection max to 50 or less...or use the upload settings from the 2nd link in my signature.

Link to comment
Share on other sites

Hmm... Okay, well I've tried your suggestions, and believe I got them all right. However, annoyingly enough, the problem still persists. It still seems to be using about 3-4k more upload speed than its supposed to, which leaves me unable to set the upload higher than about 3k before it slows me to a crawl. I even closed utorrent and reopened it just incase it needed a fresh start for the changes to kick in.

Already tried the speed settings in your sig, too. That was one of the first things I tried, actually. Even on higher settings than you recommend for my type of connection though, when its running good, having higher connections (I usually have it at 100 global connections) it doesn't seem to have any adverse effect. Though for the sake of testing, I have em set to your recommended numbers for now.

Well, sleep calls for now, I'll check back in the morning. Thank you for the swift responses though. :)

I might just wind up having to wait till its working properly again and compare test results, see where the differences are.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...