Jump to content

Poor speed, choked peers


Recommended Posts

I've got a problem- I used uTorrent ages ago, no trouble. Although recently, when trying to download a new torrent, I've been experiencing very poor speeds, and when looking at my list of peers (which is limited) the majority are choked (flagged as 'd-' that's right, isn't it?) and I'm only getting about 5 which download, at slow rates.

Seeds- <10(1500)

Peers- 30(3000)

Speeds of <5kB, both down and up, although up is generally higher.

Speed test results: 5.15Mb/s and 0.36Mb/s

My ports are forwarded correctly

Windows firewall is off and exceptions are in place for the McAfee suite

I've tried the speed guide, conservative speed guide, and various others.

Green light at the bottom

Halfopen set at 50, I used that patch (Although I'm on XP SP3- would it still work?)

ISP is BT, using their router voyager2500v and DSL.

Using DHT and encryption- tried it forced and enabled, then without legacy connections.

Note- when I tried the Ubuntu torrent, I only got speeds of around 50kB after I uncapped the download speed- so would it just be the swarm? However, when I started this torrent, I was using a laptop on a different ISP, then transferred the incomplete file and torrent. It seemed to check with no trouble, and continued from where it left off. I achieved decent speeds on the laptop, around 100kB/s.

Any help?

Link to comment
Share on other sites

BT Central ADSL ISP in UK is hostile to BitTorrent traffic, especially during peak evening hours.

Reset net.max_halfopen back to 8...setting it higher won't help in your case -- but it may make things worse!

Have you disabled Resolve IPs?

You used the 320 or 384 kilobit/second upload settings from my speed guide, right? (2nd link in my signature)

Have you tried setting outgoing encryption to FORCED...and then testing both without and with legacy (unencrypted) connections?

Link to comment
Share on other sites

I reset the halfopen back to 8, nothing much happened.

Resolve IPs was already disabled

Yeah, I used 320Kb/s.

I tried again with setting the encryption to forced- the speed went up marginally, but it was from <1KB/s to about 3, which according to the graph, had happened a few times before. It went down when I turned off legacy connections.

Any more ideas, or is just the ISP being evil?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...