Jump to content

Port Problems


Recommended Posts

I get the feeling from other posts I've seen that this is a widely found problem. However, I've yet to find a suitable solution.

According to the icon at the bottom of my uTorrent I have no incoming connections, and when I run a Port Test the only result I ever get is that the port is not reachable.

Now, before anyone says to refer to www.portforward.com (which seems to be the answer everywhere else), I already have done, but when following the tutorial for my particular modem (SmartAX MT882), the screenshots simply don't match, as it appears that TalkTalk have done something to the firmware.

While the obvious solution is to open the port in the firewall, and / or to add uTorrent to the list of exceptions, I have not only done this, but have also tried disabling all fiewalls - including the one built into the modem, yet I still meet up with the closed port error all the time, so I'm pretty sure it's not being blocked by a firewall.

I have also downloaded the PortChecker utility from PortForward.com, which, when uTorrent is running, keeps telling me that some other program is locking the ports on both TCP & UDP. However, when I close uTorrent, it only gives that error message to the UDP option - on the TCP is simply says it's not accessible - neither of which is of much help.

The curious thing is that I can download torrents via uTorrent, but cannot seed, and what's even more peculiar is that I seem to be displaying upload rates, but only on the torrents I have downloaded from.

I have tried with uPnP option set both to On & Off, but neither makes any difference. I have also set my machine up to a static IP. In fact I've tried everything I can possibly think of.

Is there some way I can force a port to open, despite it supposedly being blocked by some other application?

Link to comment
Share on other sites

I've just tried enabling the uPnP in the modem, as well as in uTorrent (which was already enabled), but still with no success.

The thing I don't understand is how the transfer speed monitor line shows a fair bit of activity, both on the red & the green lines. I can only imagine that much is being managed via DHT.

As for the firewall I'm using - that is fSecure, the combined AV / Firewall by TalkTalk, but as I said in my initial post, I have even tried disabling all firewalls, fSecure, Windows, as well as the modem firewall - all to no avail.

Link to comment
Share on other sites

I've tried doing that as well - removed all rules relating to uTorrent - both application & port ones.

I was surprised to see that although I had disabled uTorrent whilst doing so, as soon as I had removed the rules, an alert popped up to warn me of an attempted network connection to uTorrent, even though it wasn't running. Anyway, I allowed it, In & Out & made sure the rules & the ports were re-added - still nothing.

The thing is that I'm sure that this can't be blamed on the ISP, as I never used to have any problems until recently when I picked up a virus & had to do a lot of re-installing, and one of the re-installations was an up to date version of uTorrent, which has never worked properly since.

Link to comment
Share on other sites

I'm pleased to report that with the help of someone on UKChatLineOne.com I've been talked through the problem.

For the info of anyone interested, suffering from the same problem, this is how it was explained to me:

(NB This was for the TalkTalk SmartAX MT882 Modem, but the besic rules will probably apply to all)

First you have to go in to the modem type in internet explorer, or fire fox.

User name = " Admin " : password = "admin"

Now your in your Modem . Under the basic tab on the left click the '+' and in the sub menu click on NAT.

Under NAT settings click Redirect,

Now click the "New" Button.

The settings to put in here are first, Local Address is listed under your

Local Area Connection in your Task bar just right click and go to status,

On the support tab it should say your local IP address mine is put that in under Local Address.

Next, "Destination Port From" put in the number of the port you want to open

"Destination Port To" Put the same number or greater depending on haw many ports you want.

Leave the rest defalt and click submit. save your settings and you're done.

I must admit I did'nt have much confidence to start with, but lo & behold, I now have a lovely little green circle at the base of my uTorrent.

Link to comment
Share on other sites

Difficult to say without seeing your whole setup.

Personally I use a seperate hard drive for saving torrents & subsequent downloads to & leave the C drive for the OS & general software, but even if you don't have this facility available have you set up uTorrent to have a seperate directory for torrents to be saved to & for completed downloads to be moved to etc? Furthermore, are you sure that you are attempting to save the torrent to the relevant folder?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...