Jump to content

Can't Connect to Peers/Seeds


Recommended Posts

So after attempting to troubleshoot this myself for an incredibly long time, I've come to the conclusion that I need some help. Although I'm using uTorrent, I also encountered this problem with Halite.

Some info:

ISP -- Comcast

Router -- Dynex DX-WGRTR

Modem -- D-Link DCM-202

OS -- Vista

Every torrent I've tried on both private and public trackers never detects any peers or seeds. I'm on a static IP (I've tried multiple ones) and port checker says I'm OK. UPnP is off. I'm not using a software firewall. There's no traces of any of the trackers I use in my hosts file. I'm able to ping my router just fine. Really, the only discrepancy I've been able to find is that a tracert on my router times out. My two roommates using the same router are able to use BT just fine and have never encountered any problems.

And this connectivity issue seemingly came out of nowhere, as I was using uTorrent just fine only a few days ago. Anybody got any suggestions?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...