Jump to content

Any Windows 7 Issues?


Recommended Posts

Just recently upgraded to Win7. I've been using XP for years, and running utorrent for as long as I can remember. I've had the same router for about a year now. Just the first utorrent I downloaded for 7 was 2.0.

My download speeds are excellent, but my uploads are less to be excited about, usually can't get global upload to exceed 10kB/s. Before upgrading OS's, my upload was to the limit every day (running 1.8.1) using default settings. I never had to change anything except port #'s. DHT is and has always been disabled.

I know my open ports, and the status is green. I run the speed test and get anywhere from 384k to 640k depending on the time of day.

Tried Ultima's guide, changed a whole bunch of stuff to no avail. Multiple restarts of utorrent, windows, and my router.

Uninstalled utorrent and deleted all appdata and installed an old version of 1.8.1 I had saved from my previous setup, same thing.

Tried Vuze to see if the same thing happens, and it uploads like crazy seconds after I start the program, like utorrent did on XP. Only one problem there; I hate that program, and want to use utorrent.... :P

I connect to a wireless N D-Link router, but if Vuze works, doesn't that eliminate the router possibility? I can't exactly directly connect to the modem, for it's kinda far away, but I do have access to the gateway

Any specific things to check in Windows 7?

Apologies for any redundancies. Any help appreciated!

Link to comment
Share on other sites

hm didn't even know about IPv6.. Disabled it, restarted router/modem/pc nothing changed.

uTP is disabled in utorrent. bt.transp is set at 5

Went through the slow speed troubleshooter. OpenOffice acts the same as my other torrents do. Ican't even connect to a single peer on that torrent. It downloads at full speed, just can't seed it.

I disabled both windows firewall and my routers firewall just to test, but saw no change there either.

What are the usual router killers?

I'm not using any kind of zonealarm, antivirus software etc. that actively runs.

Link to comment
Share on other sites

So I went out of my way to directly connect the modem to my computer. There is no change. So that eliminates any router questions. My connectivity is just so bad.. The torrents I'm seeding have 200+ peers, but I can see 0-2 regularly. But they drop like flies :|

My modem is a Motorola Surfboard, if that matters. I was using that modem in my XP days when everything was fine and dandy.

Link to comment
Share on other sites

I am having the exact same problem, and I mean exactly the same. I've tried everything jaymzj has tried and to no avail. I too had no problems with utorrent until I upgraded to win7. I love utorrent and I would really rather not change clients...but if I can't get this resolved I will have to because I have to keep my share ratio a certain level or I can't use my fav torrent site. Here is what I find interesting, I had winxp sp2 AND win7 x64 installed on my computer before I formatted my xp partition - utorrent had no problem under xp, but win7 on the exact same computer and network does. Downloads great as before, uploads practically nonexistent - leechers connect and drop away in less than a second. Occasionally one will stick around but I have yet to have more then one person able to stay connected. I don't know what the problem is but it seems to me that it is with how utorrent handles win7. Why else would xp work fine AND alternative clients with no other changes? I hope the solution is found soon.

Link to comment
Share on other sites

When you switched from Win XP to Win 7, was Teredo/IPv6 disabled in XP?

(Teredo/IPv6 is enabled by default in Win 7.)

uTorrent will use Teredo/IPv6 if available.

Is uTP peers/seeds having issues?

Did you try disabling net.calc_overheads , bt.tcp_rate_control (in Preferences, Advanced), or uncheck Bandwidth Management to disable uTP (in Preferences, BitTorrent).

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...