Jump to content

Choking upload on one torrent kills all torrents/lags sys-clock by ~4%


Recommended Posts

I have µTorrent 2.0 and I noticed that if I choke the upload speed on one torrent, all other torrents suffer in both UL and DL speeds, whether by choking a torrent in particular, or choking it globally, regardless of the limit I set or how absurd it is (50,000kBps should be absurd enough, and I've tried it). The moment I undo those restrictions and restart µTorrent (it seems I have to restart to "cleanly" make those changes take effect, no big deal for me), the speeds on all connections immediately improve.

For example, I choke "torrent 1" to upload at no more than 200MBps with 4 other torrents running. Unchecked, I'm transferring at about 300-400 up, and up to 2.2M down total with "torrent 2", "torrent 3", and "torrent 4". I choke "torrent 1" upload to 200kBps, and all speeds fall as low as a 6kBps down, while the upload cap is maintained. I set *all* limits to "unlimited", again, and I have full speed back. Mind you I am choking a seeding torrent for UL (say, "torrent 1", and my unfinished and unrelated torrent(s) suffer in speed both ways (say, "torrent 2", "torrent 3", etc...).

I've done this repetitively and the result is the same. I put ANY regulation on one torrent and all transfer(s) suffer both ways, sort of like a republican congress. By choking any one torrent, am I somehow not getting "share" the same way, or is this a bug? I've noticed a few clients claiming to be 2.0.01 of the same name, but I doubt an upgrade of that level would somehow solve this problem...

Unlike many people who complain, I actually appreciate the simple existence of P2P, what I want to know is if I am somehow doing something wrong? Have I not configured µTorrent properly, or is there something I have missed? Most settings are default with exception to where torrent files are stored and bandwidth, but other than that, I can't find an erroneous setting.

Here are my relevant specs, to answer any anticipated questions before they come up:

Processor : AMD Athlon 64 X2 5600+ @ 2800 MHz (Dual-Core)

Physical Memory : 2048 MB (2 x 1024 DDR2-SDRAM )

Operating System : Microsoft Windows XP Home Service Pack 3

Comcast cable-internet (hsd) @45MBps+ as clocked by 3rd-party bandwidth sites (that's 45 mega BYTES per second, not megabits, this is not the common domestic package, it's business-class; Dialup is 56k megaBITS per second, which is about 3.1megaBYTES per second or so max IIRC, for comparison).

(and yes, I have ample free space for incoming files, and yes, I have tried restarting the client and the OS)

As you can see, it's not my machine lagging. I have seen this phenomena regardless of file type or size or source or tracker. This ONLY happens when I cap a transfer speed on UL or DL, and at no other time (I run unlimited, and I get it as it is available).

Simply put, capping speeds in ANY regard for ANY torrent seems to all but kill transfer speeds, even when the "seed" is on my own network. It's not my connection speed, but it seems that all other clients snub me as a result of this cap on a torrent for some reason (I see the "willing to DL" flag, yet I have no transfer). Again, the moment I lift ALL restrictions on bandwidth, it's back to "green-flag racing" again. I have already read about the WR4TG router firmware and have updated it long ago and since to absurdity, but this was never an issue with me as I have seen no change either way between XP and 98SE with 256 ram on a completely different system, and the same effect occurs, so naturally I focus on µTorrent or it's configuration as a possible culprit.

Either it's the client or how I configured it. Maybe I missed something, if someone could clarify this for me? This is not a critical issue (I can live with it), but I'd like to run this in ideal circumstances. Is there anyone particularly knowledgeable on this moreso than I am that can provide meaningful information on this/these issues?

Where does capping the UL speed of one torrent make another torrent's DL speed suffer, regardless of trackers/file size/region/Internet Service Provider/source/network speed/geography/client spec? Is this something I can fix, or do I just have to live with it (some people out there like me actually APPRECIATE that convenience comes at a price), I just want to know if I am having these problems needlessly for lack of a better way or a configuration error on my part.


Link to comment
Share on other sites

I'm on ComCast, but on a more realistic speed tier than you.

I am aware of ComCast's DOCSIS 3 service -- with 50 mbit/sec down and 10 mbit/sec up. I've heard they're "trialing" 100 mbit/sec cable in some areas.

Maybe you have that?

I've found (possibly due to an obscure uTorrent bug) that limiting torrent speeds down or up often has nasty effects on overall speed. Instead I often use priority and reduced upload slots to reduce upload on a torrent.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...