Jump to content

RSS Feed detects new torrent but does not add it


Recommended Posts

I am using the same RSS URL on my Mac as I have on my PC. It's generated from http://showrss.karmorra.info/

I've found that it does correctly detect a new torrent (the badge 1 shows in the RSS list) but it doesn't actually download it.

I have to select it and select download and then it goes. Is there some additional step or some special Mac setting I'm missing to get this to happen automatically? Do I need to generate a smart feed as well somehow?

I've searched the forums without much luck so looking for insight here. Thanks!

Link to comment
Share on other sites

Actually it does seem you need a smart feed. I added that and it worked!

It looks like the RSS tutorial doesn't apply to the Mac client. It mentions editing the feed and selecting auto-download but that's not an option. The only way to do it, at this point, is to create a smart feed based on your RSS feed and go from there...

Link to comment
Share on other sites

Yeah fair enough. I thought I had it with the smart feeds but it's still not quite working correctly.

The RSS feed from showRSS always seems to work (even though the torrents in the feed display a bit wonky as I mentioned in the other thread).

However, the downloader doesn't seem to work reliably. If I refresh the feed completely it will download everything sometimes, but if just leave it it usually does nothing.

It could be that I have it set incorrectly, but I'm not sure what else I can do with it.

Right now it's set to watch the showRSS feed, to start automatically, and to save in (that's the .torrent file I assume) the directory that uTorrent watches. Under advanced the only settings set are "contains" which is *.* (so everything "new" in the feed I guess) and the quality is "all".

So I'll just keep watching it and see what happens.

If anyone has managed to get this working, though, let me know what you did. It would be nice to put up some simple steps on the forum. If I get it going I will post the steps I took.

Link to comment
Share on other sites

Here's a bug: if you are editing smart feeds and you press "-" under the "Find Any Torrent That" section... right next to the next box you get the following error (and the display goes bad):

04-26-11 11:37:01 PM uTorrent[7670] HIToolbox: ignoring exception '*** -[NSCFArray objectAtIndex:]: index (1) beyond bounds (1)' that raised inside Carbon event dispatch


0 CoreFoundation 0x906996ba __raiseError + 410

1 libobjc.A.dylib 0x96bcb509 objc_exception_throw + 56

2 CoreFoundation 0x906993e8 +[NSException raise:format:arguments:] + 136

3 CoreFoundation 0x9069935a +[NSException raise:format:] + 58

4 Foundation 0x97b92200 _NSArrayRaiseBoundException + 121

5 Foundation 0x97ae5e12 -[NSCFArray objectAtIndex:] + 63

6 uTorrent 0x000f2b87 0x0 + 994183

7 AppKit 0x9359cc46 -[NSApplication sendAction:to:from:] + 112

8 AppKit 0x9367c465 -[NSControl sendAction:to:] + 108

9 AppKit 0x93677f12 -[NSCell _sendActionFrom:] + 169

10 AppKit 0x93677209 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 1808

11 AppKit 0x936cc8a1 -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 524

12 AppKit 0x93675c5f -[NSControl mouseDown:] + 812

13 AppKit 0x93673c68 -[NSWindow sendEvent:] + 5549

14 AppKit 0x9358c817 -[NSApplication sendEvent:] + 6431

15 AppKit 0x937d5863 -[NSApplication _realDoModalLoop:peek:] + 806

16 AppKit 0x937d4f89 -[NSApplication runModalForWindow:] + 273

17 uTorrent 0x000cc938 0x0 + 837944

18 AppKit 0x9359cc46 -[NSApplication sendAction:to:from:] + 112

19 AppKit 0x9359caf9 -[NSMenuItem _corePerformAction] + 435

20 AppKit 0x9359c7eb -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 174

21 AppKit 0x9359c6da -[NSMenu performActionForItemAtIndex:] + 65

22 AppKit 0x9359c68d -[NSMenu _internalPerformActionForItemAtIndex:] + 50

23 AppKit 0x9359c5f3 -[NSMenuItem _internalPerformActionThroughMenuIfPossible] + 97

24 AppKit 0x9359c537 -[NSCarbonMenuImpl _carbonCommandProcessEvent:handlerCallRef:] + 336

25 AppKit 0x93590c61 NSSLMMenuEventHandler + 404

26 HIToolbox 0x9608fc2f _ZL23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 1567

27 HIToolbox 0x9608eef6 _ZL30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14HandlerCallRec + 411

28 HIToolbox 0x960b17f3 SendEventToEventTarget + 52

29 HIToolbox 0x960dde87 _ZL18SendHICommandEventmPK9HICommandmmhPKvP20OpaqueEventTargetRefS5_PP14OpaqueEventRef + 448

30 HIToolbox 0x96102b90 SendMenuCommandWithContextAndModifiers + 66

31 HIToolbox 0x96102b47 SendMenuItemSelectedEvent + 121

32 HIToolbox 0x96102a5d _ZL19FinishMenuSelectionP13SelectionDataP10MenuResultS2_ + 152

33 HIToolbox 0x96284364 _ZL19PopUpMenuSelectCoreP8MenuData5PointdS1_tjPK4RecttmS4_S4_PK10__CFStringPP13OpaqueMenuRefPt + 1857

34 HIToolbox 0x962846bb _HandlePopUpMenuSelection7 + 678

35 AppKit 0x93826d2b _NSSLMPopUpCarbonMenu3 + 3938

36 AppKit 0x938270bb -[NSCarbonMenuImpl _popUpContextMenu:withEvent:forView:withFont:] + 220

37 AppKit 0x9399feed -[NSMenu _popUpContextMenu:withEvent:forView:withFont:] + 270

38 AppKit 0x9399ff8c -[NSMenu _popUpContextMenu:withEvent:forView:] + 63

39 AppKit 0x9399fd5f -[NSMenu _popUpMenuWithEvent:forView:] + 52

40 AppKit 0x93b96c49 -[NSView rightMouseDown:] + 103

41 AppKit 0x93888367 -[NSControl _rightMouseUpOrDown:] + 534

42 AppKit 0x93673d38 -[NSWindow sendEvent:] + 5757

43 AppKit 0x9358c817 -[NSApplication sendEvent:] + 6431

44 AppKit 0x935202a7 -[NSApplication run] + 917

45 AppKit 0x935182d9 NSApplicationMain + 574

46 uTorrent 0x00003032 0x0 + 12338


Link to comment
Share on other sites

And another possible bug:

When "Refreshing" the smart feed you either get a lot of this errors:

04-26-11 11:34:36 PM [0x0-0x468468].com.bittorrent.uTorrent[7608] Tue Apr 26 23:34:36imac uTorrent[7608] <Error>: unknown error code: invalid drawable

Or just one of this set (this is happening more reliably):

04-26-11 11:39:50 PM uTorrent[7690] Could not find image named 'SplitViewGrabber'.

04-26-11 11:39:50 PM uTorrent[7690] Could not find image named 'HideStats'.

04-26-11 11:39:50 PM uTorrent[7690] Could not find image named 'ShowStats.tiff'.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...