Jump to content

Possible Bug - Add File - sub path issue


Recommended Posts


Hope this is the correct area as I can but only assume that the ability is available to the webapi/ui only, so posting here. Did search if its a known issue but could not find anything (Incorrect terms ?), so if there is something already, I apologize.

I have the latest Beta build - 25329 - and WebUI - v0.381 - both the webui and my api script give the same error.

For the sake of cutting out any of my scripting, I shall use the webui only

Click Add Torrent, Browse to the file.

Select any path (I made a Directory, so the code index is 1)

Leave Sub-path empty

Torrent uploads into uTorrent

Duplicate the above, but enter anything into the Sub-path

Using Firebug it shows the following: invalid request

Same with if i post using the api


Shows: {"build":25329}


Shows: invalid request

In both the webui/api i have tried anytxt, /anytxt, \anytxt

All give the same error

I even tried changing &path to &sub_path, and it goes through, but I assume its the same as &path=

hence why it works

Any help will be much appreciated.


Link to comment
Share on other sites

It's an old, known bug (or limitation) in the backend. The sub-path doesn't work unless the directory already exists on the filesystem. Which makes the feature almost completely useless in many cases.

Edit: You'll notice it was actually mentioned in the release notes the version in WebUI in which I first implemented this.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...