Jump to content

Win7 torrent association irritation


Recommended Posts

I have searched the forums and the Internet and cannot find an answer that is good enough.

I have been using uTorrent for a great many years without a single problem; I'm currently running Windows 7 Home Premium 64bit and using 3.1.2 build26745 32bit.

When I first started to use uTorrent it worked fine. However seemingly overnight uTorrent and Windows 7 have had a falling out and now aren't talking to each other. uTorrent will not associate itself with torrents despite being ran as the Admin and Windows 7 won't add uTorrent to it's list of programs to use when it encounters .torrents even when I am telling it to do so.

Furthermore, everytime I open uTorrent, it behaves as if it's the first time it's being opened with Windows asking me "Do you want to allow this program to make changes to your computer?", including forgetting all the torrents I've previously opened.

I've tried uninstalling uTorrent and re-installing it. I've clicked "associate with .torrent files" enough times. I've tried manually adding this rule through the Control Panel and it just won't take it.

I just don't understand it at all, how can this be an overnight change? It's getting to the point where I am considering moving away from uTorrent all together, which would be a shame as does everything I want in such a tiny package.

Any help, suggestions or howtos would be much appreciated. I may have even missed a solution, I can't see one for looking!

Link to comment
Share on other sites

Absolutely nothing like that, just a normal Windows 7 install. I've even only updated it once since I've had this machine and that was before I started to install anything.

I am completely baffled by it, a quick look through regedit for a find on '.torrent' gives a few things of note:

uTorrent is set to zero-length binary value

I am not too familiar with regedit anymore to really fiddle with it, but I can tell that that's not what it should be? If I right click on a .torrent itself, I don't even get a chance to 'open with'.


This has uTorrent as the default as well as MIME type application/x-bittorrent.

My HKEY_USERS has the following too:

S-1-5-18, S-1-5-19, S-1-5-20, and S-1-5-21-2549934591-2646197474-2929698807-1000. Is this normal? The only users on my laptop is me, who is defined as an admin, and the root. Very surreal.

Link to comment
Share on other sites

  • 10 months later...

Was there any resolution? I am having the same problem with roughly the same set up. I can up/download and the program works fine, but the association button has no effect. .torrent files do not show up in the utility to set associations, and the final thorn, when I browse to uTorrent in the wizard, it does not populate in the list of programs I can use to open torrent. Would love some ideas to try.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...