Jump to content

1.8.3 & 1.8.4 flushing to disk and hectic download speed


Recommended Posts


I had version 1.8.3 installed and it was working just fine, I've had 0 problems whatsoever.

The issues started after utorrent updated automatically to version 1.8.4.

I noticed Firefox had crashed and when I restarted it the spigot plugins were installed and utorrent was at version 1.8.4. No confirmation or notice appeared.


Ever since the upgrade I can't download a torrent, especially ones where I skip files.

It starts downloading, speed is according to my isp, but after a while the download speed drops to about 9kb/s and stays there for maybe 3 to 7 minutes before it jumps up again and so on.

When the download reaches 99% the status indicator is "flushing to disk" and doesn't change.

If I quit utorrent and do a force re-check the torrent is somewhere between 70-88% complete, and when it finishes I'm back where I started.


Mac OS X 10.6.8 Snow Leopard

What I have tried so far:

-quit utorrent, deleted partfile, force re-check then start: doesn't work

-downgrade to 1.8.3 : doesn't work

-deleted utorrent and all files related, clean install (both 1.8.3 and 1.8.4): doesn't work

-set diskio.use_partfile to false (both 1.8.3 and 1.8.4): doesn't work

-set diskio.coalesce_writes to false (both 1.8.3 and 1.8.4): doesn't work

-double the value of diskio.coalesce_write_size (both 1.8.3 and 1.8.4): doesn't work

-set peer.resolve_country to false (both 1.8.3 and 1.8.4): doesn't work

-I tried using a settings.dat file that a user suggested in another post: doesn't work

The only version that I can use now is 1.6.5

I can't, for the life of me, figure out what happened.

Any suggestion is welcome, I'm stumped.

Link to comment
Share on other sites

  • 4 weeks later...
  • 5 weeks later...

Well f*** me sideways, it looks like all I had to do was check "Automatically manage bandwidth" under Bandwidth.

A couple of weeks after downgrading to 1.6.5 I decided to try again and update to 1.8.4 and the dreaded 9kb/s issue reared it's ugly head again.

I went through the settings again and though to select "Automatically manage bandwidth".

Restarted utorrent and: It works, finally.

Hope this helps other users facing similar issues.

Wasn't going to post my "fix" but seeing as the developers rarely provide a resolution I thought to lend a helping hand.

TL;DR: Check "Automatically manage bandwidth". Thanks for nothing support team!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...