Jump to content

Port open, but still stuck!


Recommended Posts

Haiya, new to these forums, so excuse me if I say anything stupid.

Anyways, for the last month or so almost every torrent I have tried to add has gotten stuck on "connecting to peers" or "downloading metadata" at least for some duration of time while I had it in there. Some files would eventually download after a few hours, but some would just stay at that.

Today I finally got around to opening the port that uTorrent was set to use, and now it is seeing the port as open, but i'm still getting the same problems.

I tried connecting to my neighbors internet, and tethering the connection through my phone to use the data from that, but it STILL won't do anything.

On top of all this, I was having this problem before I completely restored my computer, so I have tried it on windows 7, and windows 8 now.

Some torrents are downloading just fine, but that's maybe 1 out of like 10 of them. Torrents I have downloaded before are even doing this now. It's just not making any sense.

Any advice?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...