Jump to content

ActiveX Error in uTorrent 3.3.2


Recommended Posts

I don't know if this is the right forum for my problem.
I have a problem with my uTorrent 3.3.2.
Each time when I open the uTorrent window, I get a warning:

One or more activex controls could not be displayed because either:
1. your current security settings prohibit running activex 
controls on this page, or
2. you have blocked a publisher of one of the controls.
as a result, the page may not display correctly. 

The warning pop-up opens only when I am on the utorrent window.
The problem has nothing to do with IE security, because I can open pages with ActiveX controls on them and so.


I attached a picture to help with it. I tried the solution that Microsoft suggested and still the issue remains.


Link to comment
Share on other sites

I have this problem too - very annoying - can't find any thread with a solution. The threads I find via google that could hint a fix does not exist anymore.

Are uTorrent hiding a solution for this ?? Maybe its add related ?? I did not have these problems with any versions prior to version 3.3.2


Thread that ooklmao refers to above also does not seem to exist :-(


Please help with this issue.

Link to comment
Share on other sites

  • 3 weeks later...

This also worked for me, reminds me of firefox's options, though not quite.


ActiveX reminds me of IE6, even today. Also, though I don't have experience with ActiveX's state today, it still sets of some bells with me.


Why? Oh well... mabye because COMMERCIAL ADS seems to use ActiveX in uTorrent, and ActiveX is a tool to allow programming web apps to be able to access a lot more than a browser should ever allow. When a browser allows hardware access trough a plugin/"built in plugin" (aka programming language for browsers that allows access to deeper OS and HW features) and that restricting it triggers errors when ads shows up...


This bug is really about a error message. The error message is the ad that uTorrent shows. uTorrent offers more expensive ad space for people updating to the newest version, because it allows the ads to access the system (if the user have allowed ActiveX scripting language in IE).


The reason you get this error message is that uTorrent tries to allow the ad access to the whole system, and for users that enabled ActiveX in IE, this might allow ads to access the whole system. As I haven't researched further (by allowing ActiveX further access), I don't know how far ActiveX access would lead.


I would suspect this to give access to atleast user data, and probably system wide access if permissions were granted.


When ads are made to exploit ActiveX (as proven with the denial over permissions when ActiveX is required for those that have not granted permission for ActiveX elements), that is evidence of a company/organization allowing for expoiting their customers. ActiveX is not needed to show ads in the lower left corner, though in order for ads to be able to dig for more info and to be able to examine the whole system (mabye leave backdoors and such), access to run ActiveX scripts would be priceless (sure, there's a price for it, collected by uTorrent).


If uTorrent still wants users, they really need to change their business model, as this only serve to chase customers away.


Commercials in the app is acceptable for my/our use, putting a knife in your customers back isn't. I started using uTorrent a little while after Azureus made the change to Vuze and changed their business model. It had a lot of good options, though it sacrificed lightweight and privacy issues for profit. uTorrent 3.3.2 seems to be worse than Vuze, as it not only stabs the customer in the back, it's where you suddenly have 10 knives in you and you don't know why.


Thank you for the good times, and good luck in the future.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...