Jump to content

Need some help with µTorrent please.


Recommended Posts


Before i begin, i would like to apologise if i sound noobish but i am seriously not a technical person and I need some help with µtorrent, please. Thanks in advance!

I'm using a Linksys Wireless-B BEFW11S4 router.

When i did the µTorrent Port Checker, it gave me the below message,

Warning! Port 32459 can not be checked. Your browser is setup to connect through a proxy. This script will not work through proxied connections.

Please see www.portforward.com for more information if you need to map a port.

After i went to www.portforward.com to get the configurations done, i still get a red light and so i went to read the FAQ. It says,

The following modems/routers have known problems with too many global connections, limiting them to 200 or less should fix the problems:

And the µTorrent application itself turns up a red light with this message when i place my cursor over it,

Not connectable

A firewall/router is limiting your network traffic. You need to open up a port so others can connect to you.

Appreciate any help i can get, thanks!

Link to comment
Share on other sites

Try connecting directly to your modem if possible. If the light's still red, then your software firewall's blocking. If it turns green, you didn't forward properly.

I think i tried the port forwarding but it doesn't work so i restored the old settings. The lights were intially yellow but for some reason they became red after i followed the steps.

Link to comment
Share on other sites

From my expirence, Windows Firewall still blocks certain programs although their .exe have been added to Exception list. (example, uTorrent adds itself to exception list automatically)

Please try to manually open ur uTorrent's port in Windows Firewall.

Go to Start -> Settings -> Control Panel. Find Windows Firewall and double click it.

Once it is opened, go to Exceptions tab, click Add Port

Type in a name and than the port for your uTorrent. (Please try to use a port range from 49152 to 65535)

If you see something like this, click Add.


Add port again, the same port, but this time for UDP. (Select the UDP radio button)

And most importantly, make sure you have that port forwarded in your router too.

Try to connect uTorrent again. I hope that helps.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...