Jump to content

ISP Drops me when downloading. Please help!


Recommended Posts

Under normal use, my internet is fine, but within minutes of starting utorrent I get kicked off my ISP. Only unplugging the router and modem restores my connection. I've read and tried a lot of things to try and fix this, but nothing works. I ran TCP/IP optimizer for my connection, and patched the tcpip.sys file according to the script in the speed guide (numbers below)


Comcast HSI (6M/b down, 384 K/b up)

Motorola Surfboard SB4200 Modem

Linksys BEFW11S4 Wireless Router/Firewall (With latest firmware, and MTU set to 1500 from TCP/IP Optimizer Value)

Latest Intel Motherboard Drivers

Latest NIC drivers

TCP/IP Optimizer Program gave me a max MTU of 1500.

Utorrent Settings from "Settings Optimizer Script" from forum

Network Options › Global maximum upload rate: 35

Network Options › Alternate upload rate: 42

Network Options › Global maximum download rate: 690

Torrent Options › Global maximum number of connections: 384

Torrent Options › Maximum number of connected peers per torrent: 48

Torrent Options › Number of upload slots per torrent: 8

Advanced Options › net.max_halfopen: 192

The following from the optimizer script confused me.....

Note that you must apply LvlLord's TCP/IP patch. This setting should be approx. 50% of your upload speed (in kilobits/s).

Does this note apply to the net.max_halfopen value or does this mean I patch tcip.sys file to 192? or 384?

I also set "protocol encryption" in utorrent to "forced" and unchecked the legacy box.

I tried lowering net.max_halfopen value to default, and turning DHT off. Ports are forwarded properly, as I get a green

light at the bottom, connect up to over 200 nodes, and download quickly until I'm disconnected...

1) Does it appear that I have my settings correct?

2) Is my modem or router affected by the new round-robin feature?

3) Any other ideas?

Thanks in advance.

Link to comment
Share on other sites

I think I figured this out....been running over 12 hours now with no disconnect. I setup utorrent again as described above, but then in the advanced options I set the following....

peer.disconnect_inactive to false (meaning it's activated)

then i set

peer.disconnect_inactive_interval to 250 (later changed it back to default of 300) with no problems.

I think what happens is that too many connections are left stagnant if this option is not activated, and that somehow overloads certain modems/routers/isps.....whatever. I'll post again if I get dropped again using these settings.

Hope this helps.

Link to comment
Share on other sites

alright...thought i had it but no such luck! I've been reading so much and still can't find anythign for sure.

My SB4200 modem is running firmware anyone know if this is the latest? does it handle larger numbers of TCP connections?

What about the BEFW11SR V3.0 router/firewall? Are these routers crap for P2P? Any links discussing this?

Really getting tired of searching for solutions!

Link to comment
Share on other sites

Change global max connections to 200

half open connections change to 100

LvlLord's TCP/IP patch patch to 120

peer disconnect interval *600

Make sure your router firmware is updated

Download Cablenut and use these settings

DefaultReceiveWindow = 768000

DefaultSendWindow = 49152

DisableAddressSharing = 1

InitialLargeBufferCount = 200

InitialMediumBufferCount = 480

InitialSmallBufferCount = 640

LargeBufferSize = 819200

MaxFastTransmit = 64000

MediumBufferSize = 150400

Priority Boost = 0

SmallBufferSize = 12800

TransmitWorker = 32

FastSendDatagramThreshhold = 4096

EnableFastRouteLookup = 1

EnablePMTUDiscovery = 1

IgnorePushBitsOnReceives = 0

GlobalMaxTcpWindowSize = 151840

MaxFreeTcbs = 8000

MaxHashTableSize = 16384

MaxNormLookupMemory = 5000000

SackOpts = 1

SynAttackProtect = 1

Tcp1323Opts = 1

TcpLogLevel = 1

TcpMaxDupAttacks = 3

TcpMaxHalfOpen = 100

TcpMaxHalfOpenRetired = 80

TcpRecvSegmentSize = 1460

TcpSendSegmentSize = 1460

TcpTimedWaitDelay = 30

TcpUseRFC1122UrgentPointer = 0

TcpWindowSize = 151840

MaxConnectionsPer1_0Server = 20

MaxConnectionsPerServer = 10

DefaultTimeToLive = 64

DefaultUserTOSSetting = 0

TcpMaxDataRetransmissions = 6

DefaultTOSValue = 240

restart your PC

Link to comment
Share on other sites

ndoggac's settings:

Torrent Options › Number of upload slots per torrent: 8

Advanced Options › net.max_halfopen: 192

For net.max_halfopen value, the optimizer script you're using is DEAD WRONG. (Not your fault though, just whoever made it is by no means an expert on the subject...nor am I, but that one's way off.)

For all but the fastest connections, it is only a tiny gain to increase net.max_halfopen value beyond the default of 8...and then you have to fight with Microsoft updates constantly setting your patched tcip.sys file back to default, causing massive problems!

If you intend to run multiple torrents at once, reduce your upload slots considerably -- to 4 (the default!) or even lower if you have 4+ torrents typically going at once.

Link to comment
Share on other sites

Even with lowered settings recommended above, I'm still getting the dropped connections. I think the only conclusion is hardware issues....

I've read around a little more and read about the linksys router (befw11s4) maintaining stale tcp connections for 5 days. any truth to this?? if this is true, this is what could be killing my modem. i've read that the wrt54g version 4 or before can be updated with 3rd party firmware to customize this setting. I think I'm going to try this next. why linksys wouldn't update their firmware for the befw11s4 to fix this stupid setting is beyond me.

If this new router doesn't solve the problem, I'll probably end up getting a new modem too.....dang....more money!! grrr.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...