• Announcements

    • Bommuraj Paramaraj

      Important Security Advisory   06/07/2016

      On June 6th, 2016, BitTorrent was made aware of a security issue involving the vendor which powers our forums.
      The vulnerability appears to have been through one of the vendor’s other clients, however it allowed attackers to access some information on other accounts. As a result, attackers were able to download a list of our forum users. We are investigating further to learn if any other information was accessed.Our vendor has made backend changes so that the hashes in the file do not appear to be a usable attack vector. As a precaution, we are advising our users to change their passwords. While the passwords may not be used as a vector on the forums, those hashed passwords should be considered compromised. Anyone using the same password for forums as well as other places is strongly advised to update their passwords and/or practice good personal security practices.


This topic is now archived and is closed to further replies.


uTorrent Server on Ubuntu Server

3 posts in this topic

Hi all,

I was searching the internetz high and low, can't seem to find an answer to this. Can I install uTorrent Server with a web interface on a headless Ubuntu Server?

Is it meant for this too or will I be creating vulnerabilities?

How do I go about doing this? Do I just follow the same instructions as for the Ubuntu Desktop version?

Can I point a subdomain to it, or do I have to use a domain and a port to get to the interface?

Thank you all for your help!

Share this post

Link to post
Share on other sites

Thank you very much!

Installed everything correctly, works great if I start it manually, just unable to load at it boot. Tried setting it up with webmin (Bootup services), tried creating a file with the command in /etc/init.d/, nothing makes it start at boot.

Webmin reports:

Failed to start utorrent.service: Unit utorrent.service is not loaded properly: Invalid argument

Also tried adding it to /etc/rc.local which does actually make it start, but then webmin does not

Any chance of some more help with this please?

Thank you!

Share this post

Link to post
Share on other sites