Jump to content

403 forbidden


Recommended Posts

Hi fellow forum members,

I've got the following problem :

when I want to activate a torrent I get the following message :

Forbidden (403)

CSRF verification failed. Request aborted.

You are seeing this message because this site requires a CSRF cookie when submitting forms. This cookie is required for security reasons, to ensure that your browser is not being hijacked by third parties.

If you have configured your browser to disable cookies, please re-enable them, at least for this site, or for 'same-origin' requests.


Reason given for failure:

    CSRF cookie not set.

In general, this can occur when there is a genuine Cross Site Request Forgery, or when Django's CSRF mechanism has not been used correctly. For POST forms, you need to ensure:

  • Your browser is accepting cookies.
  • The view function passes a request to the template's render method.
  • In the template, there is a {% csrf_token %} template tag inside each POST form that targets an internal URL.
  • If you are not using CsrfViewMiddleware, then you must use csrf_protect on any views that use the csrf_token template tag, as well as those that accept the POST data.

You're seeing the help section of this page because you have DEBUG = True in your Django settings file. Change that to False, and only the initial error message will be displayed.

You can customize this page using the CSRF_FAILURE_VIEW setting.

I get this after choosing a torrent on Idope.

When I return to the Idope page and try to connect via the download button, I get through to my Utorrent page and can start the download.

This problem returns each time I try the first time to download from Idope.


I have got an secondary problem though.  Today after succeeding to download, my Utorrent blocked.  I got as message in my language : 'reageert niet meer', translated ; does no longer react, I suppose.  I thought, I wait a while and it will be fixed by itself.  It didn't at all.  It is important to mention that the download link was active because it stood among the other downloads, ready to start.  But Utorrent got stuck and I closed the Utorrent, in order to restart Utorrent.  Curiously, the last download was no longer among my list of downloads ! I thaught, I have to request the download anew, did this and got a, to me, puzzling answer : this link is already active, do your want to add trackers.   Whether I choose yes or no, same result.  Closed down my laptop completely to restart, same result.  What could be the reason and how can I get Utorrent to really start this download or is it hidden somewhere ?

Sorry for my English, I'm not a native English speaker.

Many thanks in advance for your help in these matters.  Cheers !





Link to comment
Share on other sites

  • 2 weeks later...

403 isn't something utorrent can fix that is from the server side itself or your ISP is blocking something. What browser are you using and what addons do you have for like blocking ads or something to that nature? My experience with Chrome is that it doesn't play nice with torrent files.

Edited by PiusX
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...