Jump to content

Di-624/NIS 2007/Cable and no download but can upload - FRUSTRATED!!!


Recommended Posts


What have I done wrong? I have been wrangling with the my laptop for 4 nights making changes to get uTorrent to do its job with no success.

Here is my story…

I D/Ld Azureus 12 months ago, it didn't perform so I stopped bother chasing the elusive Torrent download and stuck to good old SLSK. Recently after hearing of my friends successes with D/Ling interesting Torrents I decided to bin Azureus and went for uTorrent.

I D/Ld uTorrent and it auto configured and within no time I was hitting 20-30kb/s speeds, waa-hooo!!! We are off!! But wait… After a few hours I had to reboot my modem and exit uTorrent and repeated ad infinitum.

Next I learned of how to optimise uTorrent and made some setting changes… WAA-HOOO speeds of up to 160kb/s, now that's what I am talking about, but alas, after 10mins beeeeeeeeeeeeeeeeeep – flatline. Reboot, and it starts but after 1min beeeeeeeeep – flatline.

Thought process #1 – Ensure static IP is set. Ok, Im off to portforward.com and I will do this, Check!


Thought process #2 – Ensure port is forwarded. Ok, Im off to portforward.com and I will do this, Check!

Thought process #3 – Ensure my router is configured as per above, check!



Thought process #4 – Norton Internet Security is blocking traffic. Ok, Im off to portforward.com and I will do this, Check!


Other things done : In uTorrent disabled UPnP, maintain 1 port for uTorrent.

My set up

Router = D-Link DI 624 (Rev C – haven't updated the firmware and won't till I get this sorted)

Firewall = Norton Internet Security 2007

Connection = Cable (Virgin) 2meg

Download speed = 235 kp/s

Upload = 40 kp/s

My queries

1. Should the Private IP address for uTorrent be Static = 192. 168. 0.136 or the standard 192. 168. 0. 100 that comes up when I run ipconfig/all?

2. My provider is cable and dynamic – Am I supposed to disable DHCP within my router, if so how do I do this?

3. Why does uTorrent say my port is not correctly forwarded but continues with uploads but not downloads?

4. Why is uTorrent permitting uploads but denying decent download rates?

Where does the error lie as I am about to go mad, 10+ hours spent on this with no breakthrough!!!

Thanks people,


Link to comment
Share on other sites

Cheers DreadWingKnight,

Your first link didnt work, the second has been link RE Set Up, I have done all of that too

One question, could you clarify what tab/location etc you mean in reference to your comment "Don't touch the internet side configuration in the router"


Link to comment
Share on other sites

I get you RE Internet side... Will look at the other link RE firewalling. Cheers

I have looked at your other link and it is a nice visual representation of my plight, but how do I get passed this nightmare stage?

If you check the JPEGS is there anything to suggest my port is not open (ie forwarded properly?). Am I right in saying that the only 2 places the port is to be open is in my Router and Norton?

Why is uTorrent saying my port isn't forwarded also? Please look at the jpges and tell me if you spot something wrong, I have read and re-read portforward numerous times and I have set the Static IP to as stated in Portword too.

One other thing, when reading problems/solutions and set up guides PRIOR to posting this thread I read that DHCP had to be disabled, is this the case? When I run ipconfig/all it states DHCP is enabled - is this causing my prob? As the reply to may queries read - DO NOT TOUCH THE INTERNET SIDE OF YOUR CONNECTION, surely this means I can't disable DHCP?

Please some take a look at the JPEGS I have attached above and see what I can do next.

One last thing, if it a case of picking bad torrents can anyone suggest if there is such a thing as a speed test torrent or the like?



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...