Jump to content

µtorrent disk cache = literally ON THE DISK


Recommended Posts


I been using µtorrent for some time now - i REALLY like it. It's a great app. Best BT client i ever used - except that i got this problem with it.

I download/upload stuff on daily basis, so i started to think about adjusting the µtorrent's cache settings trying to minimize disk access. I got 2 gigs of ram so i could easily give out some memory for µtorrent to use as cache. So i gave it like 256 megs and adjusted the settings for minimal access (or at least so i thought).

Then later on i popped up the good ol' taskmgr and realised that µtorrent's disk cache which i woulda imagined to be in the RAM (in order to minimize disk access) was COMPLETELY in the paging file. And oh yeah, the paging file is located on the hard disk. So much for the disk access minimizing, since the cache IS on the hard disk.

Needless to say i got really depressed.

Needless to say i stopped using it immediately. Normally i would be downloading at the moment, but no. I got so sad when i realised that because of this disk cache (LOL) behaviour my hard disk would probably break.

Oh Boy, in this case disk cache literally means DISK cache.

I have been searching this forum, and found many posts about ppl havin the same issue, but i can't find a solution.

Help me, i'm a sad panda.

oh yeah - some pc info

windows xp professional

outpost firewall pro

p4 3.2 Ghz HT / 2 GM RAM

SATA150 hard disks

Windows cache settings ->For Programs

Link to comment
Share on other sites

HI there. Thx for the response. I'm not using any RAM freeing applications, i know how they work and yes they would do that, free up phys. memory by using virtual mem.

I don't get it what's doing this. It's really frustrating, i guess the only way to avoid it would be to disable the paging file completely.

As i stated earlier i'm not using RAM Freeing appz or any other special appz.

In outpost firewall pro i have disabled all but DNS Cache plugin.

I'm behind a router.

None of the hardware/software i use are in the incompatible list.

However i have noticed many other posts about this same issues, but haven't found any common denominator.

Also, i guess the vm stays in it's place with the default settings. But if one dares to go and touch the disk cache settings, then virtual memory automatically grows, and grows and grows...it sucks. i'm frustrated and depressed. Why is this happenin to me? God hates me.

And if i dare to minimize µtorrent, it drops to like couple 100 K, flushing even the little amount of megabytes of memory it uses. So now, even IF it would cache to the memory, it would have to do it all again. I'm so angry at the world now.

I tell you how you can reproduce the situation. Go to Preferences -> Advanced -> Disk Cache. Next, adjust the settings how you would imagine to minimize the need to access the hard disk. click OK.

Now start a torrent (make sure you are uploading that torrent too). Voila ! Situation reproduced !

Fire up the taskmgr and watch µtorrent "cache" to the virtual memory, thus doing nothin to minimize disk access.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...