Jump to content

4kB-10kB upload... -_-'


Recommended Posts

Ok, ever since I have the new build, 1.7.2, I'm having upload issues.

These didn't occur before today! I had set a file to download, and when downloading, the upload went about 100 kB/s.

It was after this download, the upload went no further than 4kB/s per file!


As you can see, I didn't limit the upload speed, and I checked my settings, and nowhere I can find anything that looked suspicious enough for me that it would limit my download.

I can't figure out why I can't upload with +/- 100 kB/s. My internet is 4MB/1MB (512kB/s/128kB/s real).

Don't tell me it's my firewall, or router, because it worked fine before, only now, for some reason, not anymore.

I tried finding another topic about this, but couldn't, so here I am :)

Eh, help?

Link to comment
Share on other sites

Your ISP may be throttling your BitTorrent upload traffic.

Have you tried reducing the number of active torrents and global connections per torrent to see if the upload speed gets at least a little higher?

Another thing is try setting the upload speed max to 10, 20, 30, etc KiloBYTES/sec and see if µTorrent ever at least breaks the 5 KiloBYTES/sec upload barrier it seems to have.

Link to comment
Share on other sites

I've set Global maximum number of connections back to 200 (was 1000, but never had a problem before with that), and the option below (Number of maximum peers connected per torrent) also to 200.

It does not make any difference, it keeps to 4 kB/s per torrent.

Maybe stupid question, what is ISP? (sorry, for english not being my main language ;))

Link to comment
Share on other sites

ISP = Internet Service Provider = what company provides your internet connection

I recommend trying only 50 global and per-torrent connection max for awhile and see if it at least reaches 5 or 6 KiloBYTES/sec upload speed.

Try also disabling DHT, UPnP, and Resolve IPs (right-click in PEERS window).

Link to comment
Share on other sites

I don't mean to sound rude or anything, but eh, I never had this problem before. I have currently 3 active torrents, and all are not seeding more than 4.0 kB/s!!!

I did not alter any settings before, and my router is open to all connections from µtorrent.

I'm clueless.

I reduced the settings back to 50 now, but still not seeing any progress in more speed :s


Fixed it. I uploaded a screenie in case people ask this question again. Thanks for the help!

How-to-fix screenie

Link to comment
Share on other sites

Wow, possible/probable bug!

Btw, unless you have a totally badass connection...50 torrents at once is really bad settings. You'd end up uploading less than 1 KiloBYTE/sec per torrent probably...and each torrent has their own set of upload slots, so per upload slot the upload speed might be 0.3 KiloBYTES/sec.

Link to comment
Share on other sites

That's some funky stuff... I can't seem to reproduce the problem consistently, but I have reproduced it. Probably is a bug :|

It took me several re-reads of this thread until I realized what the problem was, so I'll just summarize it quickly right here:

Even though "Limit the upload rate to" is unchecked in Preferences > Queueing, the limit set in the field still seems to take effect. It didn't happen immediately until I tried messing with it a few times. Stopping and starting the torrent, or even restarting µTorrent doesn't fix the problem until I change the setting.

After doing a bit more testing, I realized that "Limit the upload rate to" sets an actual per-torrent upload rate limit on the torrent that reaches the seeding goal, so it seemed like I was able to reproduce the problem after unchecking it.

In short, I can't reproduce the problem still.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...