Jump to content

"Set download location" problem


Recommended Posts


uTorrent 1.7.5

Windows Vista x64

I have a problem with "Set Download Location..." feature.

If torrent have file(s) in directory, i can't set another download location (rename directory) because "Browse For Folder" window has only Desktop item.

If torrent have file w/o directory, everything is fine, i can set another file name.

P.S. Sorry for my english.

Link to comment
Share on other sites

  • 3 weeks later...

Er, confuzzled here O.o

I'm not sure what I apparently "understood" in my previous post, but I seem to have lost it, as the first post doesn't sound much like a bug report any longer... It sounds more like a misunderstanding of how the add torrent dialog works.

If you want to set the download location for a torrent with subdirectories, µTorrent will allow you to select the parent directory to put those subdirectories in only. If you want to change the name of the root subdirectory, you're going to have to change it after you select the parent directory (via the editable combobox in the Add New Torrent dialog).

Link to comment
Share on other sites

OK i try explane with screenshots


Let's say i want to move partialy downloaded torrent to another location. I stop it. Move files manualy to another folder, when i click "Set download Location", and i get this.


Only thing i can do it's a create new folder on desktop, and nothing more.

Or i want to seed torrent. I can't set download location to folder with files, i'm compelled to copy/move folder to my default download location and rename it to name in torrent.

Sorry for my english, hope you understand what i meen.

Link to comment
Share on other sites

Oh... Gotcha. I misunderstood your mention of "set download location" to be setting the download location from the add torrent dialog (I didn't take it literally). I understood it before, but failed the second time around... Somewhat sad :<

Though not exactly the same problem, it falls into the same category as this previously reported issue (being another problem with the SHBrowseForFolder dialog).

Link to comment
Share on other sites

Some update.

I did't try registry update because my comp have this entries, and on vista they have different value.

I'm not mention (sorry about this) but i'm using "user" account, and looks like problem in this. If i run utorrent from admin account all work fine. I'm tried ProcessMonitor, but did't find "Access Denine" entries, so i try look some more.

Link to comment
Share on other sites

Log into Vista with administrator privileges. Then set uTorrent.exe to run with administrator privileges: http://technet2.microsoft.com/WindowsVista/en/library/0d75f774-8514-4c9e-ac08-4c21f5c6c2d91033.mspx?mfr=true

Test it by logging out and logging in as a regular user. If you can save the torrent files to other places besides the Desktop, uTorrent.exe has admin privileges.

Link to comment
Share on other sites

  • 3 months later...

So heres another way to do this so that it works. And it is a Vista problem btw.

Find your root uTorrent.exe file.

Right click goto properties.

If your running Vista (which you are because your having this problem), there should be a tab that says compatibility. Under that tab, click the checkbox that states "run this program in compatibility mode for" and from the drop-down menu, pick Windows Xp SP2 ...


He had the right idea running uTorrent under administrator, but I wouldn't feel safe. Letting uTorrent run as administrator could be bad news. This way I think would be better and safer. The fewer programs you have running as administrator the less chance you leave for potential bugs and the such. Makes sense right?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...