Jump to content

v 1.8 latest version will not always open folders.


Recommended Posts

I am using the most up to date version of v 1.8. downloaded from the official site.

Right clicking a downloaded file opens up the usual options, and all of them work consistently bar one.

If the download is available to open directly, it does so perfectly every time.

If the download is available as 'open containing folder' it sometimes works and the folder will open, but most times it will NOT work and the file will refuse to open. The files line in the downloaded list stays dark blue hightlighted and shows no sign if going to light Grey. I am forced to access the file using the slower route of find and open using 'Start', 'My Documents', 'Downloads' etc.

If the file is available to open directly in a player (I use GOM Player) it works fine, but its second option to 'open containing folder' usually refuses to operate.

This is the only problem that I have encountered using v 1.8 through several updates! I have held back expecting that this may work itself out, but so far it has not.

I have not found anyone else with this problem report it... is it just me to find this?

I run: XP 3200 32 bit. 1GB RAM

Link to comment
Share on other sites

iirc, uT uses ShellExecute to open the path under "Save As"... On single or multi-file torrents Open Containing Folder is always available because of this.

I'm not sure what you mean by light grey unless it's the torrent status you're talking about http://utorrent.com/faq.php#What_do_the_red_icons_mean_on_the_torrent_status_icons.3F

:( The only time I don't get the folder opened I get a popup and it says


Windows Explorer


The path '' does not exist or is not a directory.




What path are you trying to save to? Are you sure the file has downloaded something? The operation will fail until one complete piece is dumped to disk.

Link to comment
Share on other sites

"I'm not sure what you mean by light grey unless it's the torrent status you're talking about"

I have several completed files shown in the main field of Micro Torrent. If I select one of them, by clicking it once, that line with all the data on it is highlighted in dark blue. If I right click that item, it opens a new window with options to 'Open File' or 'Open Containing folder' and others.. If I have the choice to 'Open File' it will do so every time. and as it does so, the line highlighted in blue in the list of item downloaded will lighten to pale grey! That is what I mean here. Of course, if I click to 'Open Containing Folder' it refuses to open that item AND the item remains highlighted in dark blue, and the folder refuses to open. That item IS ALL THERE. I can access it if I surf to the folder and open it that way but Not when I want Micro Torrent to do the same task. Is that clearer now?

The path I use to download to in 'Downloads' in Windows on my 'C' drive, which I believe is the default route set by Micro Torrent? I have never swapped it from the start. The path does exist I assure you because the programme has downloaded it ALL there for me.


Link to comment
Share on other sites

OHHH! Right :) Sorry, indeed. You're talking about when uT loses focus. Indeed the highlight changes colouring. It depends on your windows appearance settings actually. My highlight is black, with a 80% grey background... and the inactive highlight is off-brown.

The default at least for XP and above is actually the user's my documents folder \Downloads. So you don't have the "put new downloads in" folder changed from default in Preferences (Ctrl-P)? There's no popup or anything when uT doesn't open the folder? Could you go to How-To for Troubleshooting search near the bottom for "Process Explorer" and follow the procedure to make a DLL list for utorrent.exe, and then copy-paste that into a post below?

Link to comment
Share on other sites

"There's no popup or anything when uT doesn't open the folder? "

Indeed there is not. It simply does nothing at all. No pop-up, and no reaction whatsoever, and the files stays highlighted in dark blue.

I know that setup changes colours and appearance.


"Could you go to How-To for Troubleshooting search near the bottom for "Process Explorer" and follow the procedure to make a DLL list for utorrent.exe, and then copy-paste that into a post below?"

Yes and I will be back when I have...




And later... here it is

Process PID CPU Description Company Name

System Idle Process 0 94.12

Interrupts n/a 2.94 Hardware Interrupts

DPCs n/a 0.98 Deferred Procedure Calls

System 4

smss.exe 1052 Windows NT Session Manager Microsoft Corporation

csrss.exe 1176 Client Server Runtime Process Microsoft Corporation

winlogon.exe 1200 Windows NT Logon Application Microsoft Corporation

services.exe 1244 Services and Controller app Microsoft Corporation

svchost.exe 1408 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1500 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1624 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1704 Generic Host Process for Win32 Services Microsoft Corporation

svchost.exe 1860 Generic Host Process for Win32 Services Microsoft Corporation

spoolsv.exe 348 Spooler SubSystem App Microsoft Corporation

eEBSvc.exe 1824

schedul2.exe 448 Acronis Scheduler 2 Acronis

AWCSER~1.EXE 652 Boost Service IObit

BOCore.exe 948 COMODO BOClean - Anti-Malware COMODO

cmdagent.exe 1016 Comodo Agent Service COMODO

ekrn.exe 1028 Eset Service ESET

SAgent2.exe 1560 EPSON Printer Status Agent SEIKO EPSON CORPORATION

A2SERV~1.EXE 1700 a-squared Service Emsi Software GmbH

nvsvc32.exe 2432 NVIDIA Driver Helper Service, Version 162.18 NVIDIA Corporation

svchost.exe 2684 Generic Host Process for Win32 Services Microsoft Corporation

alg.exe 3060 Application Layer Gateway Service Microsoft Corporation

lsass.exe 1256 LSA Shell (Export Version) Microsoft Corporation

explorer.exe 392 Windows Explorer Microsoft Corporation

ctfmon.exe 404 CTF Loader Microsoft Corporation

BOC425.EXE 616 COMODO BOClean - Anti-Malware COMODO

TrueImageMonitor.exe 624 TrueImage Acronis

schedhlp.exe 632 Acronis Scheduler Helper Acronis

cfp.exe 664 COMODO Firewall Pro COMODO

egui.exe 688 Eset GUI ESET

mamutu.exe 732 0.98 Mamutu Emsi Software GmbH

SOUNDMAN.EXE 756 Realtek Sound Manager Realtek Semiconductor Corp.

rundll32.exe 772 Run a DLL as an App Microsoft Corporation

msmsgs.exe 788 Windows Messenger Microsoft Corporation

phototoolkitmem.exe 804 Photo Toolkit Plugin VicMan Software

TeaTimer.exe 812 System settings protector Safer Networking Limited

BWMonitor.exe 824 Bandwidth Monitor BWMONITOR.COM

Typing Assistant.exe 832 Typing Assistant Sumit Software

VersionTrackerPro.exe 1112 VersionTracker Pro Windows CNET TechTracker

uTorrent.exe 2064 µTorrent BitTorrent, Inc.

explorer.exe 3616 Windows Explorer Microsoft Corporation

msimn.exe 3192 Outlook Express Microsoft Corporation

firefox.exe 2316 Firefox Mozilla Corporation

FSCapture.exe 2764

procexp.exe 2188 0.98 Sysinternals Process Explorer Sysinternals - www.sysinternals.com

etRiskMon.exe 1460 East-Tec Eraser 2008 EAST Technologies

Process: uTorrent.exe Pid: 2064

Name Description Company Name Version

a2handler.dll a-squared Hook DLL Emsi Software GmbH 3.00.0000.0443

ACTIVEDS.dll ADs Router Layer DLL Microsoft Corporation 5.01.2600.2180

adsldpc.dll ADs LDAP Provider C DLL Microsoft Corporation 5.01.2600.2180

ADVAPI32.dll Advanced Windows 32 Base API Microsoft Corporation 5.01.2600.2180

appHelp.dll Application Compatibility Client Library Microsoft Corporation 5.01.2600.2180

ATL.DLL ATL Module for Windows XP (Unicode) Microsoft Corporation 3.05.2284.0000

browseui.dll Shell Browser UI Library Microsoft Corporation 6.00.2900.2995

CLBCATQ.DLL Microsoft Corporation 2001.12.4414.0308

COMCTL32.dll User Experience Controls Library Microsoft Corporation 6.00.2900.2180

comdlg32.dll Common Dialogs DLL Microsoft Corporation 6.00.2900.2180

COMRes.dll Microsoft Corporation 2001.12.4414.0258

CRYPT32.dll Crypto API32 Microsoft Corporation 5.131.2600.2180

CRYPTUI.dll Microsoft Trust UI Provider Microsoft Corporation 5.131.2600.2180

CSCDLL.dll Offline Network Agent Microsoft Corporation 5.01.2600.2180

cscui.dll Client Side Caching UI Microsoft Corporation 5.01.2600.2180


DNSAPI.dll DNS Client API DLL Microsoft Corporation 5.01.2600.2938

FotoTaggerToolbar.dll FotoTaggerToolbar Module 2.02.0000.0018

GDI32.dll GDI Client DLL Microsoft Corporation 5.01.2600.3159

hnetcfg.dll Home Networking Configuration Manager Microsoft Corporation 5.01.2600.2180

ieframe.dll Internet Explorer Microsoft Corporation 7.00.6000.16608

ieframe.dll.mui Internet Explorer Microsoft Corporation 7.00.6000.16414

iertutil.dll Run time utility for Internet Explorer Microsoft Corporation 7.00.6000.16608

imagehlp.dll Windows NT Image Helper Microsoft Corporation 5.01.2600.2180

IMM32.DLL Windows XP IMM32 API Client DLL Microsoft Corporation 5.01.2600.2180

Iphlpapi.dll IP Helper API Microsoft Corporation 5.01.2600.2912



kernel32.dll Windows NT BASE API Client DLL Microsoft Corporation 5.01.2600.3119


MPRAPI.dll Windows NT MP Router Administration DLL Microsoft Corporation 5.01.2600.2180

MSASN1.dll ASN.1 Runtime APIs Microsoft Corporation 5.01.2600.2180

MSCTF.dll MSCTF Server DLL Microsoft Corporation 5.01.2600.2180

msctfime.ime Microsoft Text Frame Work Service IME Microsoft Corporation 5.01.2600.2180

msvcrt.dll Windows NT CRT DLL Microsoft Corporation 7.00.2600.2180

mswsock.dll Microsoft Windows Sockets 2.0 Service Provider Microsoft Corporation 5.01.2600.2180

NETAPI32.dll Net Win32 API DLL Microsoft Corporation 5.01.2600.2976

Normaliz.dll Unicode Normalization DLL Microsoft Corporation 6.00.5441.0000

ntdll.dll NT Layer DLL Microsoft Corporation 5.01.2600.2180

ole32.dll Microsoft OLE for Windows Microsoft Corporation 5.01.2600.2726

oleaut32.dll Microsoft Corporation 5.01.2600.3266

oledlg.dll Microsoft Windows OLE 2.0 User Interface Support Microsoft Corporation 5.01.2600.3016

OLEPRO32.DLL Microsoft Corporation 5.01.2600.2180

PSAPI.DLL Process Status Helper Microsoft Corporation 5.01.2600.2180

rasadhlp.dll Remote Access AutoDial Helper Microsoft Corporation 5.01.2600.2938

RPCRT4.dll Remote Procedure Call Runtime Microsoft Corporation 5.01.2600.3173

rtutils.dll Routing Utilities Microsoft Corporation 5.01.2600.2180

SAMLIB.dll SAM Library DLL Microsoft Corporation 5.01.2600.2180

Secur32.dll Security Support Provider Interface Microsoft Corporation 5.01.2600.2180

SETUPAPI.dll Windows Setup API Microsoft Corporation 5.01.2600.2180

SHDOCVW.dll Shell Doc Object and Control Library Microsoft Corporation 6.00.2900.2987

SHELL32.dll Windows Shell Common Dll Microsoft Corporation 6.00.2900.3241

shfolder.dll Shell Folder Service Microsoft Corporation 6.00.2900.2180

SHLWAPI.dll Shell Light-weight Utility Library Microsoft Corporation 6.00.2900.2995



TA.dll Typing Assistant DLL Sumit Software 3.00.0000.0000


urlmon.dll OLE32 Extensions for Win32 Microsoft Corporation 7.00.6000.16608

USER32.dll Windows XP USER API Client DLL Microsoft Corporation 5.01.2600.3099

USERENV.dll Userenv Microsoft Corporation 5.01.2600.2180

uTorrent.exe µTorrent BitTorrent, Inc. 1.08.0000.9272

uxtheme.dll Microsoft UxTheme Library Microsoft Corporation 6.00.2900.2180

VERSION.dll Version Checking and File Installation Libraries Microsoft Corporation 5.01.2600.2180

WININET.dll Internet Extensions for Win32 Microsoft Corporation 7.00.6000.16608

winrnr.dll LDAP RnR Provider DLL Microsoft Corporation 5.01.2600.2180

WINSPOOL.DRV Windows Spooler Driver Microsoft Corporation 5.01.2600.2180

WINTRUST.dll Microsoft Trust Verification APIs Microsoft Corporation 5.131.2600.2180

WLDAP32.dll Win32 LDAP API DLL Microsoft Corporation 5.01.2600.2180

WS2_32.dll Windows Socket 2.0 32-Bit DLL Microsoft Corporation 5.01.2600.2180

WS2HELP.dll Windows Socket 2.0 Helper for Windows NT Microsoft Corporation 5.01.2600.2180

wshtcpip.dll Windows Sockets Helper DLL Microsoft Corporation 5.01.2600.2180

Link to comment
Share on other sites

Truthfully it sounds like something to do with those multiple Comodo processes for mal/spyware.

Unfortunately I don't know what can be disabled/stopped as it's not in the SFCT http://forum.utorrent.com/viewtopic.php?pid=292343#p292343 :/

a2handler.dll a-squared Hook DLL Emsi Software GmbH 3.00.0000.0443

FotoTaggerToolbar.dll FotoTaggerToolbar Module 2.02.0000.0018



OLEPRO32.DLL Microsoft Corporation 5.01.2600.2180

TA.dll Typing Assistant DLL Sumit Software 3.00.0000.0000

is a list of dlls I don't recognize. You also have a higher than expected Interrupt and DPC usage... sign of a larger problem, IMO.

ivbar is apparently part of "Photo Toolkit"... if you could close that the problem might go away(This is the right photo toolkit yes? http://www.siteadvisor.com/sites/qlbe.com/downloads/8482184/ ). Additionally that typing assistant or that asquared service ma be at fault. Try turning off/removing them to see if the problems go away.

As far as the DPC usage, it may be your bwmonitor... if you notice your system sluggish when you're downloading fast or making new peer connections (at the beginning of starting a torrent) you may want to look in the manual to see if it includes some extra unnecessary processing like DNS on connections. I know it has to keep track of packets somehow... but I haven't used it so I can't be of any more service.

Link to comment
Share on other sites


I have uninstalled: 1) Foto Tagger

2) Typing Assistant.

3) Photo Toolkit.

I switched off the Comodo Firewall and its BO Clean Trojan scanner. There is a firewall in ESET Security Suite which I left operating.

I switched off my BW monitor.

After doing all this Micro Torrent will still not 'Open Containing Folder'

So we know what it isn't from your list! We do not know what it is however.

I really do like your programme and yes, I have tried just about every one out there so this is not an empty observation. It is a pity that something here at this end is causing some conflict as it is just me that seems to be affected. The function that is in trouble is one I use OFTEN, and that is what makes it an irritation to me. Other Torrent programs WILL open folders by the way... it is a problem unique to your program.

Thats about all I can say... ^%$£"

Thanks for looking and trying to unravel this quirk in the system.


Link to comment
Share on other sites

:( What OS are you on? Are you running as a limited user? I'm not sure where it would show up but I'd imagine if you switched over to handles (Ctrl-H) mode in Process Explorer it might show the function passing the open information to explorer.

Additionally I know Process Monitor also by sysinternals allows in-depth evaluating of process integrity. If you look through the creator's blog for instance, he shows step-by-step how he makes fixes to things. http://blogs.technet.com/markrussinovich/ All I can suggest is getting some information and trying to debug it yourself ... perhaps comparing the open command in azureus and seeing how far uT follows that and where it fails and paste that log information in the thread for someone more knowledgable to look at :(

Link to comment
Share on other sites

Here I am on XP Home with all updates included...

Limited user?? I do not follow you.

I will try what you suggest but tomorrow... It is late here.

I wish that you could help... Would an analysis from Hijack this help?



Link to comment
Share on other sites

Not likely. That will only show what's installed but not running or extra services running... It sounds like something is either intercepting or killing the request to open.... You didn't change your default shell did you?

By limited user I mean not-administrator.. certain actions like setting filetype associations require elevated privileges :( I haven't come across this before, so I'd start with Process Monitor and log all actions which happen in azureus and uT (you can filter by PID in the program... but you'll need to look at both explorer.exe and the torrent client actions)

Link to comment
Share on other sites

The day after the night before..

I have replaced the photo packages that I deleted last night because I use them a lot...

I did nothing else... And I must add that removing them did not cure my problem last night...

Today. I have checked out my uT list of downloads, and lo and behold, they all open in

"Open Containing Folder"!

What answered my problem... I have no idea, but it now works. Software can be fickle and pernicious at times...

So, thank you jewelisheaven for your help and ministrations. My fingers remain crossed that it says fixed...


Link to comment
Share on other sites

I have left my reply for several days to make sure my comments are valid.

When I checked my list of removed / replaced programmes, and I noticed that I had removed Typing Assistant as well as 3 Image Processing programmes. I have reinstalled all three of my Image Processing programmes and still find my problem has been cured, but I have not replaced Typing Assistant, which I hardly ever used anyway. It is possible that that item was my nemesis, and I wont be reinstalling it to find out either!

I have downloaded the latest incarnation of uT 1.8, and it still hooks to open folders and the selected download, so I am happy to say that my problem is solved..

Thank you sir for your assistance.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...